WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 weeks ago

#38566 closed defect (bug) (worksforme)

Dashicon font is rejected by Firefox

Reported by: Clorith Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.5
Component: Customize Keywords:
Focuses: Cc:

Description (last modified by Clorith)

When loading up the customizer (independent of which theme is used), Firefox complains about the dashicon font being used as it is rejected by their sanitizer.

The exact error output from Firefox

downloadable font: rejected by sanitizer (font-family: "dashicons" style:normal weight:normal stretch:normal src index:0) source: http://192.168.1.4/wp_vanilla/wp-includes/fonts/dashicons.eot  

My test site is at http://192.168.1.4/wp_vanilla/ in the above example.

It is being triggered at dashicons.css:1:12, this only occurs in the customizer, anywhere else using dashicons in the admin appears fine.

Change History (3)

#1 @Clorith
5 years ago

  • Description modified (diff)
  • Summary changed from Dashicon font is rejected by FireFox to Dashicon font is rejected by Firefox

#2 @westonruter
5 years ago

  • Milestone changed from Awaiting Review to Future Release
  • Version changed from trunk to 4.5

To clarify, it's the Firefox “sanitizer” not a customizer sanitizing function. This is not related to the new Custom CSS feature in 4.7 and I could see the Dashicons error back in 4.5 (I didn't look back further) so it's not a new issue. Firefox is complaining about this rule in dashicons.css:

@font-face {
        font-family: dashicons;
        src: url(../fonts/dashicons.eot);
}

Since this rule gets immediately overridden by the non-EOT rule, it's going to be thrown away anyway. It's not clear why Firefox is reporting an error here, but it's not impacting the rendering in any way.

Aside: This is no longer needed in the customizer since IE8 is no longer supported and IE9 supports non-EOT formats. Granted this stylesheet is enqueued outside the customizer as well.

Resolving this will require some sleuthing on Firefox idiosyncrasies.

#3 @celloexpressions
5 weeks ago

  • Milestone Future Release deleted
  • Resolution set to worksforme
  • Status changed from new to closed

I can no longer reproduce this with Firefox 88, which might mean this was fixed on the browser's end sometime in the past several years. I'm closing for now, but if anyone else is still seeing this issue please reopen.

Given the note above that the EOT format is no longer required for browser support, removing that from the dashicons CSS would be another potential fix.

Note: See TracTickets for help on using tickets.