WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#38575 closed defect (bug) (fixed)

REST API: Correctly test the roles parameter when creating a user

Reported by: jnylen0 Owned by: rachelbaker
Milestone: 4.7 Priority: normal
Severity: normal Version: 4.7
Component: REST API Keywords: has-patch
Focuses: Cc:

Description

This test for creating a user was never updated from role to roles as part of https://github.com/WP-API/WP-API/pull/2177. Therefore the new user's role was not being set or tested as intended.

Attachments (1)

38575.diff (1001 bytes) - added by jnylen0 4 years ago.

Download all attachments as: .zip

Change History (4)

@jnylen0
4 years ago

#1 @jnylen0
4 years ago

  • Keywords has-patch added

#2 @rachelbaker
4 years ago

  • Owner set to rachelbaker
  • Resolution set to fixed
  • Status changed from new to closed

In 39043:

REST API: Correctly test the roles parameter when creating a user in WP_Test_REST_Users_Controller.

Props jnylen0.
Fixes #38575.

#3 @rachelbaker
4 years ago

  • Milestone changed from Awaiting Review to 4.7
Note: See TracTickets for help on using tickets.