WordPress.org

Make WordPress Core

Changes between Initial Version and Version 1 of Ticket #38645, comment 3


Ignore:
Timestamp:
11/03/2016 06:53:23 PM (3 years ago)
Author:
nerrad
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #38645, comment 3

    initial v1  
    1 I like this, I think it provides a clear way for client code to "properly" reset the `WP_Roles` instance if necessary.  The only suggestion I would have is to rename the `for_blog` method to `reset_for_blog` or `set_for_blog` or `init_for_blog`.  I think just `for_blog` is a bit ambiguous about the method purpose.  However, I understand if for consistency sake with other places this similar naming schema is used you keep it as is.
     1I like this, I think it provides a clear way for client code to "properly" reset the `WP_Roles` instance if necessary.  The only suggestion I would have is to rename the `for_blog` method to `reset_for_blog` or `set_for_blog` or `init_for_blog`.  I think just `for_blog` is a bit ambiguous about the method purpose.  However, I understand if for consistency sake with other places this similar naming schema is used, you keep it as is.