WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 5 months ago

#38870 closed defect (bug) (worksforme)

Error when using Emojis as WordPress Post-Tags

Reported by: andigun Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.6.1
Component: Emoji Keywords:
Focuses: ui, javascript Cc:
PR Number:

Description

I found a problem with Emoji support, when using emojis as tags.
One can add emojis as tags and even as slugs. Once you have used a emoji as tag, this emoji appears in edit mode under the Link "Choose from the most used tags" inside the "Tags-Box".
If you click the emoji there, the input-field above is focused, but the emoji isn´t filled in and the field stays empty.

Change History (4)

#1 @swissspidy
3 years ago

  • Summary changed from Error when using Emojis as Wordpress Post-Tags to Error when using Emojis as WordPress Post-Tags

#2 @johnbillion
3 years ago

  • Component changed from Taxonomy to Emoji

#3 @petitphp
2 years ago

I try but coudn't reproduce this bug. I tried several locales and WordPress releases and was able to add/use emojis as tags.

This could be related to the ticket #35792 (tldr: some locale seem to be using a . has tag delimiter which break the regex in tagBox.clean() method).

#4 @pento
5 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

I was also unable to reproduce this.

I'm going to close this issue, as there don't appear to have been other reports.

This issue can always be reopened if there are reliable steps to reproduce it.

Note: See TracTickets for help on using tickets.