WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#38885 closed enhancement (duplicate)

add_to_blog is not handled in wp-activate.php when new user is added to site in user-new.php

Reported by: warrenreeves Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.6.1
Component: Networks and Sites Keywords:
Focuses: multisite Cc:

Description

Following on from the issue in #26855, there is no feature which looks for the add_to_blog meta key and shows a home url to the user based on that

On line 128 there is currently a check for the key 'blog_id' but there is no check for 'add_to_blog'.

To recreate, add a new user is to a site in user-new.php, when the user clicks on the link in the activation email, wpmu_activate_signup() returns a $result that does not contain the blog_id key (which is the only key being checked). add_to_blog key is passed but there are no checks in place and the if statement goes to code which shows links to the network home when the links on this page should be the home url and login link of the current site.

Change History (2)

#1 @Mista-Flo
4 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #39311.

#2 @netweb
4 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.