WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 4 months ago

#39058 closed defect (bug) (duplicate)

W3C Validator error: Element dl is missing a required instance of child element dd

Reported by: henry.wright Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.6.1
Component: Gallery Keywords: needs-patch
Focuses: Cc:
PR Number:

Description

The W3C Validator gives an error when using the gallery shortcode. Here's an example:

[gallery link="file" columns="2" size="large" ids="746,745,741,740"]

I believe markup should be:

<dl>
    <dt></dt>
    <dd></dd>
</dl>

Example of what is being output:

<dl>
    <dt></dt>
</dl>

Change History (2)

#1 @desrosj
8 months ago

  • Component changed from General to Gallery
  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to Future Release

I am able to reproduce this when using the Classic Editor, or the Classic block in the new block editor. The theme must not have support for HTML5 galleries.

#2 @pento
4 months ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #47665.

Note: See TracTickets for help on using tickets.