WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#39068 closed defect (bug) (duplicate)

Admin bar retains site language in front end

Reported by: joedolson Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7
Component: I18N Keywords:
Focuses: administration Cc:

Description

If you've selected a user language, the admin bar is only in your selected language while you're in the admin.

Steps to reproduce:

1) Add at least one additional language to system.
2) Go to User Profile and select a different language
3) Visit site front end; admin bar will be in the system language instead of your user selected language.

Change History (2)

#1 @davidakennedy
4 years ago

  • Keywords needs-patch added

@joedolson and I tested this together at WCUS Contributor day. I first noticed it because when using the RTL Tester plugin for theme testing. There seemed to be an issue when switching to a RTL language. The Admin bar on the front end would not get the proper styles. We suspected this could be related to user admin languages, and tested.

#2 @swissspidy
4 years ago

  • Keywords needs-patch removed
  • Milestone 4.7 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #38643.

That's currently by intention, as a few bugs need to be resolved first.

See #26511 and especially #29783 for discussions and background.

Note: See TracTickets for help on using tickets.