WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#39086 closed defect (bug) (duplicate)

Major bug: wpdb->get_results always returns ARRAY_N

Reported by: prodev Owned by:
Milestone: Priority: normal
Severity: blocker Version: 4.7
Component: Database Keywords:
Focuses: Cc:
PR Number:

Description

Hi everybody,

It appears the latest nightly build has some kind of bug in the wpdb->get_results() function, no matter what type you request it always returns ARRAY_N, this looks like a major bug and needs to be fixed ASAP.

Change History (2)

#1 @prodev
3 years ago

  • Severity changed from normal to blocker

#2 @swissspidy
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #39075.

Hey there,

Thanks for your report. As the same issue was just reported yesterday, I'm marking this one as a duplicate.

It would be great if you could chime in on that ticket and give some more information, perhaps some test code to replicate the issue.

Note: See TracTickets for help on using tickets.