WordPress.org

Make WordPress Core

#39102 closed defect (bug) (fixed)

Customize: Shift-click on placeholder nav menu items fails to focus on the nav menu item control

Reported by: westonruter Owned by: westonruter
Milestone: 4.7.1 Priority: normal
Severity: normal Version:
Component: Customize Keywords: has-patch commit fixed-major
Focuses: Cc:

Description

When you shift-click on a nav menu item in the customizer preview, the corresponding nav_menu_item control should be focused in the pane. However, currently when adding a new nav menu item in the customizer, shift-click is focusing on the nav menu location control as opposed to the nav menu item control.

Attachments (1)

39102.0.diff (715 bytes) - added by westonruter 10 months ago.

Download all attachments as: .zip

Change History (8)

#1 @westonruter
10 months ago

  • Keywords has-patch added

The fix is trivial. We just have to account for placeholder nav menu ids being negative in the regular expression: 39102.0.diff.

Note that this would eventually be made irrelevant by #38072.

#2 @westonruter
10 months ago

  • Owner set to westonruter
  • Status changed from new to accepted

#3 @westonruter
10 months ago

  • Milestone changed from 4.7.1 to 4.8

This isn't a defect introduced in 4.7.

#4 @westonruter
10 months ago

  • Resolution set to fixed
  • Status changed from accepted to closed

In 39562:

Customize: Fix ability to shift-click on placeholder/pre-saved nav menu items in preview to focus on corresponding control.

Fixes #39102.

#5 @westonruter
10 months ago

  • Keywords commit fixed-major added
  • Milestone changed from 4.8 to 4.7.1
  • Resolution fixed deleted
  • Status changed from closed to reopened

While technically this issue existed before 4.7, I think actually it will be much more noticeable with starter content since shift-click on the menus won't open the nav menu item controls as a user would normally expect for nav menus that are already saved. So I'm milestoning this tiny fix for 4.7.1.

#6 @celloexpressions
10 months ago

Agreed that this should be in 4.7.1. It's a regression from previous behavior, closely tied to changes in 4.7, and the fix is trivial.

#7 @dd32
10 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 39572:

Customize: Fix ability to shift-click on placeholder/pre-saved nav menu items in preview to focus on corresponding control.

Props westonruter.
Merges [39562] to the 4.7 branch.
Fixes #39102.

Note: See TracTickets for help on using tickets.