WordPress.org

Make WordPress Core

Opened 4 years ago

Last modified 3 years ago

#39128 assigned defect (bug)

ERROR MESSAGE "non existing changeset UUID" — at Version 19

Reported by: RomainVB Owned by:
Milestone: Future Release Priority: normal
Severity: normal Version: 4.7
Component: Customize Keywords: needs-patch
Focuses: Cc:

Description (last modified by westonruter)

Milestoning for tracking.

Change History (21)

@RomainVB
4 years ago

Copie de mon écran

#1 @westonruter
4 years ago

  • Component changed from Help/About to Customize
  • Keywords reporter-feedback added

@RomainVB welcome. What are the steps that you took to cause this error to appear?

What theme and plugins are active on your install?

#2 @swissspidy
4 years ago

#39161 was marked as a duplicate.

#3 @sixsigmablackbelt
4 years ago

wordpress 4.7


Accelerated Mobile Pages
Advanced AMP ADS
AMP
Cookie Consent
Disable Emojis
Disable XML-RPC Pingback
Email Address Encoder
Glue for Yoast SEO & AMP
Google Analytics by MonsterInsights
Optimus
Sticky Menu (or Anything!) on Scroll
Table of Contents Plus
TablePress
TinyMCE Advanced
Umleitungen
WP Minify Fix
WP Super Cache
Yoast SEO

#4 @westonruter
4 years ago

@RomainVB @sixsigmablackbelt and this error appears in the preview immediately upon loading the customizer or does the site frontend appear momentarily and then update to show the error message? Also, are you loading the customizer initially with a changeset_uuid query parameter appearing in the URL?

#5 @westonruter
4 years ago

This error message is printed out in the WP_Customize_Manager::setup_theme() method:

<?php
/*
 * If unauthenticated then require a valid changeset UUID to load the preview.
 * In this way, the UUID serves as a secret key. If the messenger channel is present,
 * then send unauthenticated code to prompt re-auth.
 */
if ( ! current_user_can( 'customize' ) && ! $this->changeset_post_id() ) {
        $this->wp_die( $this->messenger_channel ? 0 : -1, __( 'Non-existent changeset UUID.' ) );
}

If you just authenticated, then the current_user_can( 'customize' ) check should return true, so I don't see why this condition would be entered into.

@sixsigmablackbelt
4 years ago

log on

#6 @sixsigmablackbelt
4 years ago

i take this link
http://www.sixsigmablackbelt.de/wp-admin/
then check the customizer button
after that i get the message with this url
http://www.sixsigmablackbelt.de/wp-admin/customize.php?return=%2Fwp-admin%2F

i take the right password into the field
check the submit button
i get the message log on
after some seconds i get the message your session is time out
beetween i saw the message with the uuid on the screen

see also the versuch.wmv file

#7 @westonruter
4 years ago

@sixsigmablackbelt I'm having trouble opening that file. Would you please upload it to YouTube?

#9 @westonruter
4 years ago

  • Milestone changed from Awaiting Review to 4.7.1

Milestoning this to 4.7.1 so it can be on our radar to identify what the problem is.

From looking at your plugins, @sixsigmablackbelt, the best guess I have is that WP Super Cache is the culprit. Is it possible for you to deactivate the plugin temporarily to see if it is the issue? Likewise are you able to deactivate other plugins selectively to identify if one of them are causing the problem? Naturally this would be best to do on a staging environment if you have one.

@RomainVB Do you also have WP Super Cache enabled?

#10 @sixsigmablackbelt
4 years ago

You are right. It is the WP Super Cache. After deactivating the plugin, everything was ok. Thanks a lot for your advice.
Roland

#11 @westonruter
4 years ago

@sixsigmablackbelt would you share the configuration you have? I was able to reproduce a problem with WP Super Cache whereby changes weren't appearing in the preview after refreshing. But I wasn't able to reproduce the problem with the error message appearing.

I've opened an initial pull request for WP Super Cache to fix the issue, though I'm not sure if it will fix the original issue reported here. PR: https://github.com/Automattic/wp-super-cache/pull/161

#12 @sixsigmablackbelt
4 years ago

@westonruter what you mean with configuration?

#13 @westonruter
4 years ago

@sixsigmablackbelt your WP Super Cache configuration/settings.

This ticket was mentioned in Slack in #core-customize by celloexpressions. View the logs.


4 years ago

#15 follow-up: @westonruter
4 years ago

  • Keywords close added

I'm thinking this should be closed as invalid, as it is a problem with a caching plugin.

#16 in reply to: ↑ 15 @celloexpressions
4 years ago

  • Milestone 4.7.1 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Replying to westonruter:

I'm thinking this should be closed as invalid, as it is a problem with a caching plugin.

Agreed; caching plugins need to account for the customize preview (and changesets more broadly). If there are things that core can do to facilitate this or avoid what sounds like a potential compatibility issue with 4.7, let's work to identify those and get those into specific tickets.

#17 @dd32
4 years ago

#39420 was marked as a duplicate.

#18 @pagelab
4 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

This error message appeared to me when the WordPress and Site address fields in Settings > General were mistakenly set with different values.

The message disappeared when the fields were synced.

Other users out there that reported the same solution: https://wordpress.org/support/topic/non-existent-changeset-uuid/

Tested with WP 4.7 and Twenty Sixteen theme, no plugins active.

#19 @westonruter
4 years ago

  • Description modified (diff)
  • Keywords close removed
  • Milestone set to 4.7.2

@pagelab I'm not sure why that would be. So the issue appears if the siteurl and home options differ, even when the two domains point to the same WP install accessed via a different URL? In other words, when you say the two values were mstakenly different, did one value contain the domain with the www whereas the other did not?

Note: See TracTickets for help on using tickets.