WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#3915 closed defect (bug) (invalid)

Unknown column 'link_count'

Reported by: Denis-de-Bernardy Owned by:
Milestone: Priority: low
Severity: normal Version:
Component: Template Keywords:
Focuses: Cc:

Description

I got a few reports with this error:

> "WordPress database error: [Unknown column 'link_count' in 
> 'where clause'] SELECT * FROM wp_categories WHERE cat_ID > 0 
> AND link_count > 0 ORDER BY cat_name ASC"

wp-includes/category.php seems to be only place with an occurence of link_count > 0.

D.

Change History (2)

comment:1 @markjaquith8 years ago

Sounds like the 2.1 upgrade didn't go as planned. You might try manually decrementing the database version number (stored in the database). This will allow an upgrade, which should fix the database. Or, perhaps the user lacks ALTER privs in MySQL.

comment:2 @foolswisdom8 years ago

  • Milestone 2.1.3 deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Summary changed from Frequent issue? to Unknown column 'link_count'

Closing as INVALID for now.

Denis-de-Bernardy,please:

  • Include WordPress version and other environmental information
  • "Frequent issue?" is not a useful Summary
  • Do not set the Milestone
  • Please search the forums before posting bugs.

ADDITIONAL DETAILS
The cause of this issue is likely that database is not upgraded from pre-2.1, that in turn is likely a result of not all of the WordPress files being uploaded/replaced successfully which not triggering the database upgrade. Or the user does not have priv to alter the mysql.

Note: See TracTickets for help on using tickets.