WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#39169 closed defect (bug) (duplicate)

Error 500 after 4.7 update.

Reported by: wurdey Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7
Component: General Keywords:
Focuses: Cc:

Description

I was having the same issue, and I believe it might be an actual bug in wordpress.

The issue is in wp-includes/object-cache.php. If APC is not enabled in php, wordpress sets “_wp_using_ext_object_cache” to false, but also manually adds a filter to $GLOBALS[‘wp_filter’][‘all’][-100][‘apc_not_actually_running’]. And I think the problem is that it adds it as an array.

so, on wp-includes/plugin.php it calls $wp_filter[‘all’]->do_all_hook( $args );

This fails because $wp_filter[‘all’] is an array, so there’s no do_all_hook

I uncommented the line that sets the filter in object-cache.php (line 667 in the latest version of wp) and my install now works.

Change History (1)

#1 @swissspidy
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for your report, we're already tracking this in #39132.

Note: See TracTickets for help on using tickets.