WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#39177 closed defect (bug) (invalid)

Twenty Seventeen: weird behaviour of color slider (custom header)

Reported by: Presskopp Owned by: davidakennedy
Milestone: Priority: normal
Severity: normal Version: 4.7
Component: Bundled Theme Keywords:
Focuses: Cc:

Description

This was just confusing me massively - so here's the ticket

Attachments (2)

iris-slider.mp4 (1011.3 KB) - added by Presskopp 5 years ago.
2017_useless_color_slider.jpg (88.0 KB) - added by Presskopp 5 years ago.

Download all attachments as: .zip

Change History (5)

@Presskopp
5 years ago

#1 @westonruter
5 years ago

  • Component changed from Customize to Bundled Theme
  • Owner set to davidakennedy
  • Status changed from new to assigned

@davidakennedy is this a core issue or an issue with Twenty Seventeen? It seems related to the issue (#38993) we were troubleshooting on Saturday.

#2 @celloexpressions
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from assigned to closed

It turns out this is the expected behavior :)

The header text color is independent of the color hue option. The hue slider is working, but the changes can be quite subtle depending on the part of the page you're looking at. However, in the video you can see that the current menu item in the top menu changes color visibly, along with the scroll arrow there. It's a bit more obvious when there isn't a header image, or when you're looking at things like links, post meta, or the footer (the social menu icons change quite a bit). It's actually tweaking the hue of the dark colors as well, but it's very hard to see the difference visually there at first. It looks like the header text color is always matching that option, as it should, but if not please reopen.

#3 @celloexpressions
5 years ago

If we get more reports of confusion on this in the forums, for example, we could consider adding a description to the color scheme control to clarify how the custom hue works.

Note: See TracTickets for help on using tickets.