WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 months ago

#39181 closed defect (bug) (worksforme)

Need Debounce in Plugin Search field

Reported by: LogixTree Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.5
Component: Plugins Keywords: reporter-feedback close
Focuses: javascript Cc:

Description

Whenever, I try to search for plugin. I doesn't not wait for me to complete the typing. It just start searching whether it's one letter or complete word. A debounce timer is need at this point. Whenever a user starts typing, it will wait for 500ms seconds pause to create a search. It would reduce the ajax requests too.

Change History (5)

#1 @adamsilverstein
4 years ago

  • Component changed from General to Plugins
  • Focuses javascript added
  • Keywords needs-patch added
  • Type changed from enhancement to defect (bug)
  • Version changed from 4.7 to 4.5

#2 @adamsilverstein
4 years ago

  • Keywords reporter-feedback added; needs-patch removed

Hi @LogixTree, thanks for the bug report. I was unable to reproduce the issue you described, my search seems to be debounced and I only see the ajax request fire after I pause for a brief period. I tested in trunk on both the 'Plugins' and 'Add Plugins' screen. Here is a screencast showing the session you can see the network requests at the end of each keying sequence.

Where are you seeing the plugin search on every keypress?

#3 @adamsilverstein
4 years ago

@LogixTree can you give some more details here? where are you searching that isn't debounced? I think this is already fixed?

#4 @hellofromTonya
5 months ago

  • Keywords close added

Hello @LogixTree,

I was unable to reproduce this issue too.

@LogixTree, Is this still an issue for you? If yes, please provide feedback to help us further investigate.

  • Per Adam:

    can you give some more details here? where are you searching that isn't debounced? I think this is already fixed?

  • Try disabling all plugins and using a default theme. Is the issue resolved?

For now, I'm marking this ticket as a close worksforme candidate. Why? Adam and I are unable to reproduce. Will review when/if more feedback is given.

#5 @hellofromTonya
4 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Closing this ticket. However, if the problem persists, please reopen and provide more information to help us further investigate.

Note: See TracTickets for help on using tickets.