WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#39187 closed defect (bug) (duplicate)

Twenty Seventeen version check fails on dev source of core

Reported by: Rarst Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7
Component: Themes Keywords:
Focuses: Cc:

Description

This kill switch at starе of functions.php fails on dev checkout of core, stable 4.7 tag:

<?php
/**
 * Twenty Seventeen only works in WordPress 4.7 or later.
 */
if ( version_compare( $GLOBALS['wp_version'], '4.7-alpha', '<' ) ) {
var_dump( $GLOBALS['wp_version'], version_compare( $GLOBALS['wp_version'], '4.7-alpha', '<' ) );
// string(7) "4.7-src" bool(true)

Which further ends up as fatal error at my dev install, probably due to use of theme switcher plugin and kill switch being insufficiently foolproof. :)

Change History (3)

#2 @Rarst
3 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #38411.

Cheers, missed that one, closing as duplicate.

#3 @ocean90
3 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.