WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#39310 closed defect (bug) (invalid)

Unable to disable Avatars through wp-admin

Reported by: agrk Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7
Component: Administration Keywords: reporter-feedback
Focuses: Cc:
PR Number:

Description

When un-ticking the "Show Avatars" Under Settings -> Discussion, the setting isn't saved.

Tested with:
WordPress 4.7
Firefox ESR 45.5.1

Reproduction steps:

  • Go to Settings -> Discussion
  • Un-tick "Show Avatars"
  • Click F12, select the Network tab
  • Press the "Save changes" button
  • Right-click on the POST request to options.php
  • Copy as cURL
  • Paste cURL data in a text editor

The data should read:
--data 'option_page=discussion&action=update&_wpnonce=f889b162da&_wp_http_referer=%2Ftmp%2Fwp-admin%2Foptions-discussion.php&default_pingback_flag=1&default_ping_status=open&default_comment_status=open&require_name_email=1&close_comments_days_old=14&thread_comments=1&thread_comments_depth=5&comments_per_page=50&default_comments_page=newest&comment_order=asc&comments_notify=1&moderation_notify=1&comment_whitelist=1&comment_max_links=2&moderation_keys=&blacklist_keys=&avatar_rating=G&avatar_default=mystery&submit=Save+Changes'

Workaround:
Add "&show_avatars=0" to the data set and fire the request off from the command line using cURL

Change History (3)

#1 @swissspidy
3 years ago

  • Keywords reporter-feedback added

Hey there,

Thanks for your report.

I cannot seem to reproduce this. The setting is saved correctly. Can you check if it works with all plugins deactivated and using a default theme?

#2 @agrk
3 years ago

  • Resolution set to invalid
  • Status changed from new to closed

It does indeed seem like it's a plug-in that caused it (SQLite integration -- the only one I never turned off because this is on my dev box with no MySQL on it). My apologies for the false alarm!

#3 @swissspidy
3 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.