WordPress.org

Make WordPress Core

Opened 5 months ago

Closed 5 months ago

#39313 closed defect (bug) (fixed)

Add New button not disappearing in Distraction-free Writing mode

Reported by: ahortin Owned by: iseulde
Milestone: 4.7.1 Priority: normal
Severity: normal Version: 4.7
Component: Editor Keywords: has-patch fixed-major commit
Focuses: ui Cc:

Description

When using the Distraction-free Writing mode while editing a Page or Post, the Add New button no longer disappears. This bug seems to have been introduced in 4.7 as it was working fine in 4.6.

Here's a screenshot of what it looks like now:
https://cl.ly/023v243X3Z04

The Add New button should disappear as it did previously, along with the other elements. Not only does the button look completely out of place, just sitting there on its own above the title, it makes no sense to keep it displayed.

Attachments (1)

39313.patch (522 bytes) - added by iseuldebot 5 months ago.

Download all attachments as: .zip

Change History (7)

@iseuldebot
5 months ago

#1 @iseulde
5 months ago

  • Keywords has-patch added
  • Milestone changed from Awaiting Review to 4.7.1

This is a regression caused by [38983]. Moving to the next minor release for consideration.

Last edited 5 months ago by iseulde (previous) (diff)

#2 @iseulde
5 months ago

  • Owner set to iseulde
  • Resolution set to fixed
  • Status changed from new to closed

In 39619:

Editor: Let the Add New link disappear in DFW mode.

The link was moved outside the heading in [38983].

Fixes #39313 for trunk.

#3 @iseulde
5 months ago

  • Keywords fixed-major added
  • Resolution fixed deleted
  • Status changed from closed to reopened

#4 @ahortin
5 months ago

Just tested this and that patch works fine.

Thanks.

Last edited 5 months ago by ahortin (previous) (diff)

#5 @azaozz
5 months ago

  • Keywords commit added

Yes, patch looks good. It's not major, but good to fix in 4.7.1 imho.

#6 @iseulde
5 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 39634:

Editor: Let the Add New link disappear in DFW mode.

The link was moved outside the heading in [38983].

Merges [39619] to the 4.7 branch.
Fixes #39313.

Note: See TracTickets for help on using tickets.