WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#39322 closed defect (bug) (duplicate)

Current header image preview in Customizer is cropped

Reported by: ahortin Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7
Component: Customize Keywords: needs-patch
Focuses: ui Cc:

Description

When viewing the Header Media/Header Image panel in the Customizer, the Current header preview image is cropped so that it's really small.

You can see an example in this screenshot:
https://cl.ly/3O1T1d0Q143Q

The div that contains the image has an inline style of height: 16px; which is forcing the image to be cropped.

This image preview should obviously be larger as a preview this small makes it impossible to see what the image actually is.

I've tested this with Twenty Seventeen, Twenty Sixteen and Twenty Fifteen and the same thing is happening.

The example image above was taken using Firefox. I also tested using Chrome and although it did appear to show properly in Chrome (with Twenty Seventeen), when I tested other themes (Twenty Sixteen, Twenty Fifteen and others) I still found that some themes were cropping the image, so it's not browser specific.

Change History (3)

#1 @joemcgill
4 years ago

  • Keywords needs-patch added

I can confirm this bug, which seems to have been introduced in 4.7 and only happens when the header image is cropped. Seems like maybe a callback on the cropped event isn't firing properly to update the size of that control.

#2 @bradyvercher
4 years ago

Based on the description, it sounds like this might be a duplicate of #38559.

#3 @joemcgill
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks @bradyvercher. I had missed that other ticket, but I think you're correct. I'm going to go ahead and close this ticket in favor of #38559 and we can all pick up conversation over there.

Note: See TracTickets for help on using tickets.