Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#39326 closed defect (bug) (duplicate)

Please Restore Justify Text Button in Editor

Reported by: bryanne's profile bryanne Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7
Component: Editor Keywords:
Focuses: Cc:

Description

I've been a WordPress user for 6+ years and for the life of me, can't understand why you would REMOVE the Justify Text option from the latest version 4.7. We just upgraded and noticed this. Is this a mistake? Hopefully so! I use this all the time on my site and it's a vital editing option. Could you please restore this function as soon as possible? Does this mean that pages I have already justified will not display properly? I look forward to your reply. Thanks.

Change History (4)

#1 @tw2113
7 years ago

FWIW, as some quick info,

  1. It would only affect the quick/easy application for future posts. It would not retroactively change all existing posts.
  1. It's technically it's still fully possible to do text justification, it would just have to be typed in manually and with the right html/css. TinyMCE is just a UI to quickly apply that html/css.

#2 @pento
7 years ago

  • Component changed from Formatting to Editor
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #39244.

Thank you for the ticket, @bryanne!

Justify Text was removed for several reasons (see #27159), primarily due to it having uneven browser implementation, causes significant rendering problems with a lot of themes, and has been shown to have serious readability issues.

If you require this option for legacy reasons, I recommend you install this plugin.

#3 @jaka2360
7 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

#4 @pento
7 years ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #39244.

Hi @jaka2360!

If you want to continue discussion on this ticket, you can do that without re-opening - the open/close status is primarily for tracking reporting. The ticket can be re-opened at a later time if needed.

Note: See TracTickets for help on using tickets.