WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#3936 closed defect (bug) (fixed)

No cursor on Write Post page

Reported by: foolswisdom Owned by:
Milestone: 2.3 Priority: normal
Severity: normal Version: 2.2.1
Component: Administration Keywords: has-patch
Focuses: Cc:

Description

No cursor on Write Post page

ENV: trunk r8145
Firefox 2.0.0.2

From the dashboard I click Write a Post. The Write Post page loads, but the cursor is NOT in the title field for my to start typing.

ADDITIONAL DETAILs
Pressing Tab, and the cursor is in the Title field.

I already had drafts before doing this test.

Attachments (1)

3936.diff (608 bytes) - added by Nazgul 7 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 foolswisdom7 years ago

  • Milestone changed from 2.2 to 2.3

comment:2 Ed767 years ago

  • Priority changed from normal to highest omg bbq
  • Severity changed from normal to blocker
  • Version changed from 2.2 to 2.2.1

It appears a new problem has come to the surface that looks similar as described in this ticket but a little more severe.

I'm a firefox user and i have the latest version installed, a friend of mine (IE user) has installed the latest WP version 2.2.1 and what happens is that he can't simply write a post. The problem may be due to the visual editor being checked but this shouldn't be allowed to cause a problem.

I can't verify unfortunately because IE causes login problems now as well for me.

In Firefox the visual editor is the cause of the problem not being able to write a post that shows when published, you can place your cursor in the body field and type a post but without unchecking the visual editor it does not show when published.

The Post title does show though.

I have a previous version hosted locally on my computer and everything works fine as it should.

With the latest version it's also not possible to switch from visual to code, you're stuck with visual unless you manually uncheck it.

All in all a pretty serious problem that needs to be resolved.
A thread on the support forum has been created as well by someone else and he is not alone experiencing this problem.
http://wordpress.org/support/topic/121882

Thanks!

comment:3 foolswisdom7 years ago

  • Priority changed from highest omg bbq to normal
  • Severity changed from blocker to normal

Ed76, please open a new ticket describing this issue after reproducing and isolating the problem as best as you can. The problem I described here has simple reproduction steps and isolated impact.

Nazgul7 years ago

comment:4 Nazgul7 years ago

  • Keywords has-patch added

comment:5 markjaquith7 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [6059]) focus the cursor when writing a new post. Props foolswisdom and Nazgul. fixes #3936

Note: See TracTickets for help on using tickets.