WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

#39363 closed defect (bug) (invalid)

New custom css customizer saved as a published post

Reported by: gresakg Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7
Component: Customize Keywords: reporter-feedback
Focuses: Cc:

Description

I could not reproduce the bug and I don't know in what exact circumstances it really occurs. This is what happened:
I open theme customizer and go to "Additional css" tab.
In the preview pane I navigate to a post.
I live edit css.
I save and close the customizer.
I have not found out that the post has gone missing until next morning when colleagues reported, that a post was missing.
I searched for the post and could not find it in the admin section.
I could not find the post by post_name in the database.
I found revisions of the post in the the database and took the ID.
I made the search for that ID in the database and found a post of type custom_css and post_name identical to the slug of the theme, containing the custom css styles.
I could not yet reproduce the bug in a safe environment, because I don't have the exact copy of the system. It didn't work on my local installation.

Recovery: I managed to recover my post by changing the slug and the post type of the corrupted post in the database and then recover the content using the revisions pane in the post editing section.

Change History (4)

#1 in reply to: ↑ description @bhargavbhandari90
4 years ago

Replying to gresakg:

I could not reproduce the bug and I don't know in what exact circumstances it really occurs. This is what happened:
I open theme customizer and go to "Additional css" tab.
In the preview pane I navigate to a post.
I live edit css.
I save and close the customizer.
I have not found out that the post has gone missing until next morning when colleagues reported, that a post was missing.
I searched for the post and could not find it in the admin section.
I could not find the post by post_name in the database.
I found revisions of the post in the the database and took the ID.
I made the search for that ID in the database and found a post of type custom_css and post_name identical to the slug of the theme, containing the custom css styles.
I could not yet reproduce the bug in a safe environment, because I don't have the exact copy of the system. It didn't work on my local installation.

Recovery: I managed to recover my post by changing the slug and the post type of the corrupted post in the database and then recover the content using the revisions pane in the post editing section.

Hi @gresakg , I tried to replicate this, but can't successful.

#2 @westonruter
4 years ago

  • Keywords reporter-feedback added

#3 @superpoincare
4 years ago

I also observed this.

Is this because of Jetpack and compatibility issues?

I think Jetpack stores it as a post.

#4 @westonruter
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Additional CSS is stored in a custom post type.

Note: See TracTickets for help on using tickets.