WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#39390 closed defect (bug) (invalid)

Update to 4.7 broke front-end stylings

Reported by: yogaman5020 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7
Component: Formatting Keywords: close
Focuses: Cc:
PR Number:

Description

Hi Folks,

I want to tell you about a problem I recently had with the update to WP Core 4.7. I maintain a site at [yogastlouis.us]. The HTML on the site header was stripped out when core updated to 4.7 in early December. I don't know why the update caused this behavior. To see what the result from the update looks like, visit a staging site I maintain at [ystl.spiralwebdb.com]. You can compare the two sites to see the difference in styling.

To repeat, yogastlouis.us is running WP v4.6.1; ystl.spiralwebdb.com is running WP v4.7.

I fixed yogastlouis.us by pushing a local version of the site running v4.6.1 back up to production. I've disabled core file updates on the production version until I feel confident that WordPress will be stable enough not to strip out the HTML again from the site header.

This is not the first problem I had with a production site updating to v4.7. The same thing happened on another staging site (alb.spiralwebdb.com) just after WP updated in early December.

Change History (4)

#1 @dd32
3 years ago

  • Keywords close reporter-feedback added

Hi @yogaman5020

Can you explain further what you mean by "The HTML on the site header was stripped out" - What HTML is missing, from where?
Looking at the two sites, I can only see the responsive menu being pushed to the top by one of your plugins - I'm not sure which, and the versions of plugins installed differ. I can't see how that's caused by WordPress - unless you can provide some details which points to a change we've made that would cause it.

WordPress Trac is not for providing support, for all support issues you should head over to our Support Forums where there are people who can help diagnose issues. Trac is for reporting bugs in WordPress only.

#2 @yogaman5020
3 years ago

Hello Dion,

To understand what I mean by the statement “The HTML on the site header was stripped out”, you’ll need to open the sites [yogastlouis.us] and [ystl.spiralwebdb.com] in either Google Chrome or Firefox and use their web development inspector tools to inspect the page Elements. While you’re at it, be sure to drag the right edge of the browser screen to ensure the screen width is 1440px or greater. There’s a media query breakpoint set to 1439px above which a full navigation header appears. [Below 1440px, a single ‘Menu’ icon appears.]

At any rate, when you inspect the header using developer tools, you will observe that on the site running WP 4.6.1 (yogastlouis.us), the following HTML elements appear sequentially below the site-header:

<div class=“navigation-container>
<div class=“utility-bar-after-header”> contains social media icons
<div class=“home-gallery">
front-page widget areas

By comparison, on the site running WP 4.7 (ystl.spiralwebdb.com), the <div> containing the .utility-bar-after-header class attribute was stripped out on the front-end. I inspected the child-theme file (wp-content/themes/utility-pro/lib/structure/header.php) that passes in this class attribute. The custom callback (function) preregistered to the genesis_after_header event (hook) failed to register with WP Core. Not sure why this is happening. The callback executed perfectly in WP 4.6.1. The child theme code is unchanged between version 4.6.1 and 4.7.

#3 @dd32
3 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hi @yogaman5020

Thanks for those extra details - as far as I can tell from this, it's likely caused by your plugins or theme as the issues you note are caused by some Javascript on the page (which is not included by WordPress). I note you're running different versions (older versions) on the 4.7 site, which might affect it.

Unfortunately there's no details here which can be used to point to a 4.7 bug though, you'll need to diagnose what's happening yourself and let us know what in WordPress has changed to cause your issues.

The Support Forums are available to help diagnose issues. Your theme author may also be able to help.
I'm marking this as invalid; conversation can continue if need be, but please re-open if you've got any details on why it's a 4.7 bug and not related to a theme or plugin.

#4 @yogaman5020
3 years ago

Hi Folks,

I rebuilt the theme that was involved with the problem I first reported. The issue is now resolved. The theme works fine on WordPress 4.7.2. You can close out this ticket.

Note: See TracTickets for help on using tickets.