Make WordPress Core

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#39391 closed defect (bug) (duplicate)

fatal error Call to a member function add_filter() on array in /wp-includes/plugin.php on line 111

Reported by: herko Owned by:
Priority: normal Milestone:
Component: General Version: 4.7
Severity: normal Keywords:
Cc: Focuses:

Description

Site running WP4.6.1 on PHP 5.3.29 CGI Stable (at (mt)) was upgraded to 4.7 via admin upgrade page. Received fatal error: Call to a member function add_filter() on array in /wp-includes/plugin.php on line 111. Uploaded 4.7 manually, same error. Rollback to 4.6.1 fixed site.

Change History (6)

#2 @dd32
10 years ago

  • Milestone Awaiting Review
  • Resolutionduplicate
  • Status newclosed

This is most likely caused by an out of date W3 Total cache plugin or old/unused Object Cache being installed on the site, That's mentioned in the 4.7 master list of issues on the forums.
You'll need to update any plugins to the latest version and ensure that any wp-content/object-cache.php files are either removed or updated to the latest version available

We've fixed this in the current 4.7 branch and will be included in the 4.7.1 release in January. See #39132 for where we've fixed this.
If you'd like to test out the upcoming 4.7.1 release on your site before the release, it includes a fix for this and bunch of other issues, see the directions available here for installing the beta testing plugin.

#3 @glenroy99
10 years ago

I will have to wait for this update of 4.7.1 then, as I also have had to do a full roll back to 4.6.1 to solve the same issue.

I did not have any cache plugin active, or any Object Cache installed on the site, so that wasn't the case for me. I did the full plugin/theme check for conflicts first and was never able to recover the site until rolling back my WP version.

Hopefully they get to the bottom of this completely with the new update.

#4 @sonidave
10 years ago

Hello everyone!

I had the same problem with my site, with php5.6 and even the Wordpress 4.7.1 automatic update did'nt solve the problem. I could re-access the administration console by disbling all the plugins following this topic -> https://codex.wordpress.org/FAQ_Troubleshooting#How_to_deactivate_all_plugins_when_not_able_to_access_the_administrative_menus.3F

Hope this will help!

Regards,
David

#5 follow-up: @mahalraskin
10 years ago

Had the issue in 4.7.2 and fixed it by renaming

/wp-contents/plugins/installer

to

/wp-contents/plugins/_installer

using FTP

#6 in reply to: ↑ 5 @Jules Colle
10 years ago

Replying to mahalraskin:

Had the issue in 4.7.2 and fixed it by renaming

/wp-contents/plugins/installer

to

/wp-contents/plugins/_installer

using FTP

I can confirm that Installer 0.7.1 by OnTheGoSystems Inc. (the guys from WPML) is incompatible with WP 4.7.2

I had the same error message and disabling the plugin also fixed things for me.

Note: See TracTickets for help on using tickets.