WordPress.org

Make WordPress Core

Opened 18 months ago

Closed 18 months ago

Last modified 18 months ago

#39394 closed defect (bug) (duplicate)

Dates in RSS feeds aren't RFC compliant

Reported by: k0ral Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7
Component: Feeds Keywords:
Focuses: Cc:

Description

Hello,

In RSS feeds generated by wordpress, the <lastBuildDate> tag value is localized whereas it shouldn't be. For example (in French):

<lastBuildDate>ven, 23 Déc 2016 12:28:25 +0000</lastBuildDate>

Whereas, according to RFC 822, it should always be in English:

<lastBuildDate>Fri, 23 Dec 2016 12:28:25 +0000</lastBuildDate>

I can provide a bunch of wordpress instances exhibiting the issue (all in non-English websites):

http://10lunes.com/feed/ http://blog.rom1v.com/feed/ http://feeds.feedburner.com/lucdamas/humeurs http://tatouage.l-homme.com/feed/ http://webinet.cafe-sciences.org/feed/ http://www.commitstrip.com/fr/feed/ http://www.fiat-tux.fr/feed/

Thank you.

Change History (2)

#1 @Clorith
18 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hi there, and welcome to Trac!

I was unable to reproduce this on my own test instances, as the date remains un-localized as it should be.

I suspect that this may be a plugin or theme interfering with the feeds you have observed that are invalid.

What we do recommend in such cases is to disable any plugins, and switch to a default theme for troubeshooting, then enable them one at a time until the problem reoccurs to identify what is affecting it.

I'm marking the ticket as invaliv, but if you do come across more information you are more than welcome to update the ticket with the new details and we'll gladly review it.

#2 @dd32
18 months ago

  • Resolution changed from invalid to duplicate

Hi @k0ral and welcome to Trac!

We've fixed this in the current 4.7 branch and will be included in the 4.7.1 release in January. See #39141 for where we've handled this. If you'd like to test out the upcoming 4.7.1 release on your site before the release, it includes a fix for this and bunch of other issues, see the directions available here for installing the beta testing plugin.

Note: See TracTickets for help on using tickets.