WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#39411 closed defect (bug) (invalid)

Import Error: sql database utf8mb4 versus utf8

Reported by: vtorres7332 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7
Component: Import Keywords:
Focuses: Cc:
PR Number:

Description (last modified by dd32)

I am having an issue importing a wordpress database from my hosting service to Go Daddy and it seems to be because of the formatting of the new word press my SQL using utf8mb4 versus utf8.

This is the error that I am getting when I try to import it to Godaddy:

SQL query:

--
-- Database: `swsproje_prjctdb11`
--
-- --------------------------------------------------------
--
-- Table structure for table `wp_commentmeta`
--
CREATE TABLE IF NOT EXISTS  `wp_commentmeta` (

 `meta_id` BIGINT( 20 ) UNSIGNED NOT NULL AUTO_INCREMENT ,
 `comment_id` BIGINT( 20 ) UNSIGNED NOT NULL DEFAULT  '0',
 `meta_key` VARCHAR( 255 ) COLLATE utf8mb4_unicode_520_ci DEFAULT NULL ,
 `meta_value` LONGTEXT COLLATE utf8mb4_unicode_520_ci,
PRIMARY KEY (  `meta_id` ) ,
KEY  `comment_id` (  `comment_id` ) ,
KEY  `meta_key` (  `meta_key` ( 191 ) )
) ENGINE = MYISAM DEFAULT CHARSET = utf8mb4 COLLATE = utf8mb4_unicode_520_ci AUTO_INCREMENT =1;

MySQL said: Documentation

#1273 - Unknown collation: 'utf8mb4_unicode_520_ci' 

Could you please tell me how to correct this problem, I really need to move over this website.

Thank you in advance for your help.

Victor Torres

Attachments (1)

sql-upload-error-to-godaddy.jpg (117.6 KB) - added by vtorres7332 3 years ago.
Godaddy Error on import sql database

Download all attachments as: .zip

Change History (4)

@vtorres7332
3 years ago

Godaddy Error on import sql database

#1 @netweb
3 years ago

  • Component changed from General to Import

#2 @vtorres7332
3 years ago

Okay, I am confused by the response. What do I need to do to fix this?

Regards,

Victor

#3 @dd32
3 years ago

  • Description modified (diff)
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hi @vtorres7332 and welcome to Trac,

Trac is for reporting issues with WordPress, and is not available for support requests, for that we have the Support Forums.

In this case though, I'll note that the correct (and only supported) method of transferring WordPress sites is to perform an Export/Import, and not simply transfer databases. You may be able to use other tools that perform a WordPress site transfer too.
In the event that you want to use a database transfer though, you'll need to ensure that the MySQL version you're transferring to supports the same database collations as what your current version does - and in this case it does not.
In order to perform a SQL export/import you'd need to first convert the database from the utf8mb4_unicode_520_ci format to either utf8mb4_unicode_ci or utf8_general_ci - which depending on the content of your database may not be possible without data loss. How to do that is beyond what support I can offer you here, someone in the forums may be able to assist, or your host may be able to help you import the content.

I'm marking this ticket as invalid, as it's not a bug within WordPress, replies can be left without re-opening.

Note: See TracTickets for help on using tickets.