WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#39431 closed defect (bug) (duplicate)

Sites with sticky posts show multiple posts on first page even if set to 1 per page

Reported by: ashercantrell Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7
Component: General Keywords: close
Focuses: Cc:
PR Number:

Description

If you set your site to have 1 post per page (meaning you have to scroll/click to see the next entry) a sticky post will cause the site to display both on its first/front page.

For example, on a test site, I have the standard Hello world! post and have set my site to 1 post per page.

Upon adding a sticky post, however, the test site now shows two posts on the front page.

https://theashecan.files.wordpress.com/2016/12/shot-12312016-04-11.png

If you add a second sticky, it shows three per page.

https://theashecan.files.wordpress.com/2016/12/shot-12312016-04-13.png

This behavior seems odd. I'm not 100% positive this is a bug per se (it may be intentional/wontfix), so this report may also work as an enhancement request. If a user sets 1 post per page, it can be confusing and frustrating for it to show more than one.

Change History (2)

#1 @MattyRob
3 years ago

  • Keywords close added

Thanks for reporting this with a great amount of detail.

However, I think this is the expected behaviour for Sticky Posts. See codex entry here:
https://codex.wordpress.org/Sticky_Posts

#2 @dd32
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi @ashercantrell and welcome back to Trac.

This is by design, although a little weird I admit.

There's discussion over in #27282 for fixing this, although I don't think a clear "this should be fixed" conclusion has been reached by anyone - it's fairly well accepted that stickied posts do not paginate.

I'm marking this as a duplicate of #27282, your opinions would be greatly appreciated in that ticket!

Note: See TracTickets for help on using tickets.