WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#3951 closed defect (bug) (duplicate)

fix for postbypost archives

Reported by: flinkflonk Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.2
Component: Template Keywords:
Focuses: Cc:

Description

I just tried out some themes that show the last 10 or so posts using get_archives. After converting this to a (non-deprecated) wp_get_archives I discovered it wasn't that which broke the database query, it was the code constructing the query, adding a term to order by without actually adding the words "order by" :)

Patch attached.

Attachments (1)

fix-postbypost-query.diff (718 bytes) - added by flinkflonk 7 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 flinkflonk7 years ago

  • Keywords has-patch added
  • Milestone changed from 2.3 to 2.2

comment:2 flinkflonk7 years ago

but ok, I see this has been opened by one of the regulars (foolswisdom) as #3961 and a commit-candidate. Just remember to close this when you apply #3961 :)

comment:3 westi7 years ago

  • Component changed from General to Template
  • Keywords commit added
  • Priority changed from lowest to normal

I have closed the later ticket as a dupe of this one.

comment:4 foolswisdom7 years ago

  • Keywords has-patch commit removed
  • Milestone 2.2 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Ryan ended up committing the other one.

comment:5 ryan7 years ago

Oops.

Note: See TracTickets for help on using tickets.