Make WordPress Core

Opened 7 years ago

Closed 5 years ago

#39520 closed defect (bug) (wontfix)

Twenty Seventeen: One-column doesn't work on Blog Page

Reported by: sheriziya's profile Sheriziya Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7
Component: Bundled Theme Keywords:
Focuses: Cc:

Description

In the 2017 theme that comes bundled with Core 4.7, the one-column setting isn't accepted by the system for the blog page. I have set the setting for both my sites and as you can see on both of them, the one-column setting works for every page EXCEPT the Blog page.
Never Ending Realms: http://neverendingrealms.com
Ilse Mul: http://ilsemul.com/

At my site "Ilse Mul" the Blog page came automatically with the install.
At my site "Never Ending Realms" I created the Blog page per the instructions for having a blog page separate from the front page.

It seems the Blog page calls another header-class (page-header, page-title) then any of the other pages (entry-header, entry-title). I don't know if that's why the one-column setting isn't accepted, but I thought I'd best mention it.

Several people have mentioned this on the support forums for the theme, but no solution has come up. As you can see on my blog pages, I have used CSS to hide the title, but that, of course, didn't solve the problem.

Change History (5)

#1 @Presskopp
7 years ago

  • Component changed from Themes to Bundled Theme
  • Summary changed from 2017 One-column doesn't work on Blog Page to Twenty Seventeen: One-column doesn't work on Blog Page

#2 @Sheriziya
7 years ago

  • Keywords 2017 theme version 1.1 added

I just found that the Search results page has exactly the same problem. I've already upgraded to the 1.1 version of the theme, but that didn't help, unfortunately.

#3 @SergeyBiryukov
7 years ago

  • Keywords 2017 theme version 1.1 removed

Just removing the tags, as they're not a part of the workflow keywords used on WordPress Trac.

#4 @Sheriziya
7 years ago

With thanks to Kathryn (on the forums) and Laurel (one of the creators of Twenty Seventeen), this code solved the problem:

@media screen and (min-width: 48em) {
    .blog:not(.has-sidebar) #primary article,
    .archive:not(.page-one-column):not(.has-sidebar) #primary article,
    .search:not(.has-sidebar) #primary article,
    .navigation.pagination,
    body.blog .site-content .page-header,
    body.archive .site-content .page-header,
    body.search .site-content .page-header {
        float: none;
        margin-left: auto;
        margin-right: auto;
        max-width: 740px;
        width: auto;
    }
}

Apparently the page title is floated to the left on the blog and search results pages, but that doesn’t count as a content column.
The above code has fixed it for me. The left floating is pretty confusing on a one-column layout, but at least it's fixed now.

So, apparently this is another design thing and not a bug, I think. But seen reactions of others, saying it's not a logical design decision is an understatement I think, but it's solved now for me....

Thanks!

Not sure how to mark this now, @SergeyBiryukov Can you advice on that?

#5 @laurelfulford
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Thanks for following up here, @Sheriziya!

As you've noted, this is working as designed (though I do understand the confusion!).

I'm going to close this ticket, since the issue has been resolved for you.

If you have any questions at all, please ask!

Note: See TracTickets for help on using tickets.