WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#3955 closed defect (bug) (invalid)

Using permalinks prevents access to cgi-bin

Reported by: bryan868 Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.1.2
Component: Administration Keywords: permalinks htaccess cgi-bin
Focuses: Cc:

Description

When permalinks are enabled from the admin interface and the WordPress URI is located in the root directory, you can not access the cgi-bin. You are supplied with a 403 Forbidden error. When the WordPress generated rewrite rules are removed from the .htaccess file, then the cgi-bin functions normally again.

Trying to stop redirects for the cgi-bin using a rewrite condition has no effect.

RewriteCond %{REQUEST_URI} !^/cgi-bin/

This has been a problem since at least 2.0.3, probably longer.

Change History (5)

comment:1 foolswisdom7 years ago

  • Milestone changed from 2.2 to 2.3
  • Priority changed from high to normal
  • Severity changed from major to normal

That does not make sense to me, b/c the rewrite condition is if the directory/folder does not exist. Can you provide more details about the configuration. Is there a test that I can run on some of my systems?

comment:2 m0n5t3r7 years ago

well, I can't reproduce it; the only time I get 403 is when trying to access /cgi-bin without any script name (i.e. as a directory), and then it's not because of wordpress (Apache complains in error_log that I tried to execute a directory). I'd suggest checking your error logs and your Apache configuration again.

comment:3 Nazgul7 years ago

  • Milestone changed from 2.3 to 2.5

comment:4 bryan8686 years ago

  • Resolution set to invalid
  • Status changed from new to closed

This was a server issue. Please close.

comment:5 lloydbudd6 years ago

  • Milestone 2.6 deleted
Note: See TracTickets for help on using tickets.