WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 11 months ago

#39573 closed defect (bug) (wontfix)

Twenty Sixteen: Margin error with Portfolio and no widgets

Reported by: ashercantrell Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7
Component: Bundled Theme Keywords: close
Focuses: Cc:

Description

Using Portfolio projects in Twenty Sixteen on a site with no widgets in the sidebar leads to some strange margin issues. There's a lot of white space to the side of the content, making the text start nearly in the center, like this:

https://cldup.com/_TStsYRC4r.png

If you inspect the area, you can see some very odd margins in the CSS:

https://cldup.com/lzji2hWK-A.png

If that's difficult to read, it says there's a 389.141 left margin and a -1111.840 right margin, which is causing the unusual white space.

I did find a workaround: Adding any sidebar widgets, including a blank text widget, will correct the margin issue:

https://cldup.com/1KIYImUndw.png

The margins with the widget(s) in place look like this:

https://cldup.com/lzji2hWK-A.png

Change History (5)

#1 @SergeyBiryukov
3 years ago

  • Component changed from Themes to Bundled Theme
  • Summary changed from Margin error with Portfolio and no widgets in Twenty Sixteen to Twenty Sixteen: Margin error with Portfolio and no widgets

#2 @davidakennedy
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Created an issue here where Twenty Sixteen is maintained: https://github.com/WordPress/twentysixteen/issues/494

#3 @SergeyBiryukov
3 years ago

  • Milestone set to Awaiting Review
  • Resolution invalid deleted
  • Status changed from closed to reopened

Reopening, as Twenty Sixteen was merged into core SVN in #36497.

#4 @laurelfulford
14 months ago

  • Keywords 2nd-opinion added

I can recreate a similar issue with another plugin that creates custom post types (Events Manager).

A note from the GitHub issue about the second screenshot:

If that's difficult to read, it says there's a 389.141 left margin and a -1111.840 right margin, which is causing the unusual white space.

This looks like the styles that are used on regular posts, to create space for the post meta.

A better style for all non-post post types may have been to follow pages, which centre the title above the content. But I'm not sure how big of an issue this is, and if switching it now could cause other issues (whether that be with existing CPTs, or just causing unexpected behaviour with child themes/custom CSS).

I'm inclined to wontfix at this point, but am open to more discussion!

@davidakennedy I'd appreciate your thoughts on this one!

#5 @ianbelanger
11 months ago

  • Keywords close added; 2nd-opinion removed
  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from reopened to closed

I tend to agree with @laurelfulford on this one. The margins mentioned 389.141 left margin, -1111.840 right margin are not much different than the margins in a post - 420px left margin, -1200px right margin

I am going to close this as a wontfix

@ashercantrell if you feel strongly that this should be fixed, please feel free to reopen this ticket and state your case.

Note: See TracTickets for help on using tickets.