WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#39594 closed defect (bug) (worksforme)

Multisite Upgrade Network - cURL Attempting Port 443 on HTTP

Reported by: michael.ecklund Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7.1
Component: Networks and Sites Keywords: reporter-feedback
Focuses: multisite Cc:

Description

The "Upgrade Network" utility fails to perform it's tasks correctly in 4.7.1. cURL is connecting to each subsite through HTTP, however, the port it's attempting to use is 443 and not 80.

All sites in this network are HTTP, so everything should be done through port 80.

Here's how I discovered this:

Update from 4.7 -> 4.7.1 through the admin interface.
Immediately there after, Upgrade Network.

Warning! Problem updating http://domain.com. Your server may not be able to connect to sites running on it. Error message: cURL error 7: Failed to connect to domain.com port 443: Connection refused

I'm aware of connections refused on port 443. (Firewall rules) The problem is: It shouldn't even be attempting to connect to port 443. All the sites in the network are HTTP.

I've tested the "Upgrade Network" utility on 4.7 using another copy of the SAME exact network on the SAME exact server. It upgrades all the sites just fine.

Change History (7)

#1 @dd32
5 years ago

  • Keywords reporter-feedback added

Hi @michael.ecklund

Can you please provide some extra details about your site configuration? is it available over SSL? Are any parts of the site SSL? What are the site options/domain settings set to?

For it to attempt port 443, either the port needs to be set somewhere, or something is set as HTTPS, without knowing which it's hard to diagnose.

#2 @michael.ecklund
5 years ago

For what it's worth... I'm running WordPress behind a HAProxy Load Balancer with SSL termination.

#3 @nik1aa5
4 years ago

@michael.ecklund have you made some progress solving the issue? I get the same error with a very similar setup: Wordpress is behind a HAProxy Load Balancer with SSL.

#4 @nik1aa5
4 years ago

Sorry for thread bumping. Is there any progress on this?

#5 @becki
4 years ago

Same error message here on the wordpress 4.9.2 multisite setup doing a network upgrade of the database:

Warning! Problem updating https://fahrschule-schellhorn.de. Your server may not be able to connect to sites running on it. Error message: cURL error 7: Failed to connect to fahrschule-schellhorn.de port 443: Connection refused

Websites on the server using hitch as a SSL proxy terminator and then forward to varnish.
Using wordpress 4.9.2

#6 @becki
4 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

ups ... the problem actually was in fail2ban blocking its own IP address.
After fixing the issue with fail2ban all works fine and as expected.
Even with hitch as SSL terminator and varnish as a caching server ;)

Sorry for the false / positive!

Greetings & best wishes
Becki Beckmann

#7 @ocean90
4 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.