WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#39596 closed defect (bug) (duplicate)

Cannot import a CSV since the latest minor update

Reported by: benoitchantre Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7.1
Component: Media Keywords:
Focuses: Cc:

Description

Since the latest minor update (4.7.1), we cannot upload a CSV file in the Media.

Here's the error message : Sorry, this file type is not permitted for security reasons.

Same result with WordPress 4.6.2

Change History (4)

#1 @tobifjellner
4 years ago

  • Resolution set to invalid
  • Status changed from new to closed

First of all: This is not a bug (but rather intended functionality), and should not have been reported here. A better place would have been the support forum at https://wordpress.org/support/ or some specialized group/topic in stackexchange, facebook, linkedin or ... (add your own favorite channel here).

Anyway:
It seems csv is not included in the default list of allowed file types/mime types for media upload.
Codex: https://codex.wordpress.org/Uploading_Files

With help of a huge search engine, I found a tutorial that discusses how to add custom file types to the list of allowed files:
http://www.wpbeginner.com/wp-tutorials/how-to-add-additional-file-types-to-be-uploaded-in-wordpress/

#2 @dd32
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution changed from invalid to duplicate

Marking as duplicate of #39550 as it's likely caused by that if it previously was working for you.

#3 @benoitchantre
4 years ago

@tobifjellner Thanks for the quick feedback. As it worked previously, I thought it was a regression.

@dd32 In my case, I had no issue to upload a CSV before the latest minor update. I tested it on some sites, even a fresh install that was using 4.7. After 4.6.2 or 4.7.1, it didn't worked anymore. Thanks for the link to the other ticket.

#4 @tobifjellner
4 years ago

I've seen that the last update contains some updates to the list of allowed file types, so I guess that csv is one of the more rate types that left the list.
in addition I've seen another ticket that is being worked on with some issues around mime types. but i don't have the number.

Note: See TracTickets for help on using tickets.