WordPress.org

Make WordPress Core

Opened 3 months ago

Closed 2 months ago

#39600 closed defect (bug) (fixed)

Customizer: unable to remove title on navigation

Reported by: karmatosed Owned by: westonruter
Milestone: 4.7.3 Priority: normal
Severity: normal Version: 4.7
Component: Customize Keywords: has-patch commit fixed-major
Focuses: Cc:

Description

I went into navigation and removed title, but despite saving it stayed.

https://cldup.com/pGfWuseefR.png

Attachments (3)

placeholder-title.png (233.3 KB) - added by westonruter 3 months ago.
39600.0.diff (1.4 KB) - added by westonruter 3 months ago.
trim-input-title.mov (2.0 MB) - added by westonruter 3 months ago.

Change History (13)

#1 @westonruter
3 months ago

  • Keywords reporter-feedback added

@karmatosed I believe this is expected. When a nav menu item's label is empty it inherits its title from the object it is related with, so here “Sample Page”. However, I am confused by your screenshot because I see there is no placeholder. Do you have a blank space in there by chance?

#2 @karmatosed
3 months ago

My screenshot refers to the 'Sample Page' navigation just so it's clear what I'm expecting gone. That's what is staying.

I do not have a blank space. Whilst I don't, if this could get caused by a blank space can we fix that - seems potentially a common thing for users to do.

Even if this is expected, I'd suggest maybe we should try and have something better for users?

Last edited 3 months ago by karmatosed (previous) (diff)

#3 @westonruter
3 months ago

@karmatosed placeholder-title.png is what I see in Chrome (nevermind that “Edit Page” button added by Customize Posts).

@westonruter
3 months ago

#4 @westonruter
3 months ago

  • Keywords has-patch needs-testing added
  • Milestone changed from Awaiting Review to Future Release

And trim-input-title.mov demonstrates 39600.0.diff to trim the whitespace from an entered title (since it gets stripped upon saving anyway), ensuring that the original title of the underlying post/page will be displayed in the controls header and also in the placeholder text upon blur.

#5 @karmatosed
3 months ago

I don't seem able to replicate the issue with the patch - which is awesome! It totally seems to solve at least the issue of whitespace. I'm still not convinced I did have in video but totally unable to replicate now so lets go with this as a fix :)

#6 @karmatosed
3 months ago

  • Keywords commit added; reporter-feedback needs-testing removed

#7 @westonruter
3 months ago

  • Milestone changed from Future Release to 4.7.2
  • Owner set to westonruter
  • Status changed from new to accepted
  • Version set to 4.7

This issue was introduced in 4.7.

#8 @westonruter
3 months ago

  • Resolution set to fixed
  • Status changed from accepted to closed

In 39994:

Customize: Trim whitespace from nav menu item titles so that the underlying object's original title appears as input placeholder and in the control's title.

Whitespace is trimmed from titles in PHP when saved in any case, so this aligns the client-side behavior with what happens on the server.

Amends [38618].
See #38015.
Fixes #39600.

#9 @westonruter
3 months ago

  • Keywords fixed-major added
  • Resolution fixed deleted
  • Status changed from closed to reopened

Re-opening for minor release.

#10 @dd32
2 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 40094:

Customize: Trim whitespace from nav menu item titles so that the underlying object's original title appears as input placeholder and in the control's title.

Whitespace is trimmed from titles in PHP when saved in any case, so this aligns the client-side behavior with what happens on the server.

Amends [38618].
Merges [39994] to the 4.7 branch.
See #38015.
Fixes #39600.

Note: See TracTickets for help on using tickets.