Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#39602 closed defect (bug) (worksforme)

Setting a page on front and blog pages means theme options go.

Reported by: karmatosed's profile karmatosed Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords: needs-patch
Focuses: Cc:

Description

This seems to only be happening in my testing with Twenty Seventeen. I tried to replicate this in Pique and was unable.

If you set a static front page and select a page for the blog posts, the theme options goes away.

You can see here in a video: video link

Change History (4)

#1 @davidakennedy
7 years ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 4.8

I can confirm this. May be related to how the front page is determined.

#2 @laurelfulford
7 years ago

I’ve tested this as well - I’m seeing the same behaviour, but I think it may be correct. I do see why it would be confusing, though!

The Theme Options panel will only appear when a page is previewed in the Customizer. It doesn’t show for single posts or the blog posts page -- because of this, it will show and hide when you change the blog posts page under Static Front Page.

In the video, the Customizer preview only shows the page that will be set as the blog posts page, before and after. If you try to recreate this issue with the preview on a different page than the one you assign as the blog posts page, the Customizer will change the preview to that page, causing the Theme Options panel to hide, too.

In Pique's case, one of the controls under Theme Options doesn't use active_callback, so the panel is always visible. (It also looks like is_front_page for the front page panels, so the options for the static front page are also visible when you've set the front page to display latest posts).

Just let me know if this doesn't make sense, or if I'm missing something!

#3 @Dharm1025
7 years ago

+1 for @laurelfulford opinion. It works correct.

#4 @davidakennedy
7 years ago

  • Milestone 4.8 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

I retested this after reading feedback from @laurelfulford. I agree that it's working correctly as coded in the theme in combination with how the Customizer works. I'll close this out for now, but it can be reopened if need be.

Note: See TracTickets for help on using tickets.