WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

#39629 closed defect (bug) (duplicate)

Changelog for plugins not showing latest when viewing from plugins admin modal

Reported by: cavalierlife Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: WordPress.org Site Keywords:
Focuses: Cc:

Description

Recently I've noticed that the changelog is no longer up to date from the WordPress admin screen. If I click "View Version x.x Details" from the plugin admin screen on any site, the changelog shown in the popup modal window does not match the changelog shown if I view it from wordpress.org. This makes it impossible to know what will be updated, unless I head over to wordpress.org to read the changelog for every plugin that needs to be updated.

Change History (11)

#1 @lukecavanagh
4 years ago

@cavalierlife

Is there any caching active on the site?

#2 @cavalierlife
4 years ago

Not specifically, no, though hosts may be doing caching on their own. But this happens across the board on every site I look at, regardless of host.

Also happens when looking at it via something like mainwp.

#3 @cavalierlife
4 years ago

Just saw this being discussed at https://wordpress.org/support/topic/changelog-4-5-not-in-dashboard-plugins/ where Jeremy Herve says "... it appears to be a caching issue in the WordPress.org Plugins API. The API still returns an old version of the changelog".

#4 @dd32
4 years ago

There is caching on the w.org end, although it should be being cleared reasonably often.

I assume you're running 4.7.1 and not 4.8/trunk?

#5 @cavalierlife
4 years ago

Correct, 4.7.1 on all my own and client sites. 20+ sites on various hosts.

#6 @jeherve
4 years ago

@cavalierlife Does this happen with all plugins, or just with Jetpack?

@dd32 Here is what I referring to above when I saying "The API still returns an old version of the changelog":

https://api.wordpress.org/plugins/info/1.0/jetpack

Notice how the changelog is stuck to 4.4.2, although the readme includes information about 4.5?

However, I believe I may have found the source of the problem (for Jetpack, at least). It seems we forgot to update Stable tag here. We updated it in trunk, but not in the tag. Could that cause the API to look for the changelog in the wrong place, maybe?

#7 @dd32
4 years ago

  • Component changed from Plugins to WordPress.org site
  • Milestone changed from Awaiting Review to WordPress.org

However, I believe I may have found the source of the problem (for Jetpack, at least). It seems we forgot to update Stable tag here. We updated it in trunk, but not in the tag. Could that cause the API to look for the changelog in the wrong place, maybe?

Nah, nothing Jetpack did caused it. I can easily duplicate it, and It's affecting most plugins updated in the last week or so from what I can gather.
The tagged readme having the incorrect stable tag doesn't affect anything, the value is effectively ignored.

I'm not sure why it's just started happening - no related code changes have been made - other than perhaps some PHP7 compat changes, which may have affected it. I couldn't see any immediate causes though, but didn't look too closely.

#8 @cavalierlife
4 years ago

@jeherve It definitely happens with every plugin that has needed an update in the last week or two, on all the sites I manage. So...at least 30 I would think. I'm guessing it's just across the board, as a plugin needs updating, the changelog won't show the current one.

None of the sites I manage are running PHP 7, @dd32

Last edited 4 years ago by cavalierlife (previous) (diff)

#9 @josklever
4 years ago

This is not related to certain websites or hosting, but has to do with the localized wordpress.org versions. I.e. https://nl.wordpress.org/plugins/jetpack/changelog/ shows 4.4.2, where https://wordpress.org/plugins/jetpack/changelog/ shows the changelog up to 4.5.

A WP site uses the localized version of wordpress.org so it also is behind on the main version. This has happened a while back and it was solved later. It's some synchronization issue on wordpress.org

#10 @jeherve
3 years ago

I was able to reproduce the issue just now, and it definitely seems linked to the locale.

Steps to reproduce the issue on my end

  1. Go to Plugins > Add New on a site running the latest version of WP.
  2. Search for "WooCommerce" or "Jetpack".
  3. The changelogs are looking good.
  4. Go to Users > My Profile
  5. Change your language to French.
  6. Go back to Plugins > Add New, and search for "WooCommerce" and "Jetpack" again.
  7. The changelog tab content doesn't match the current version, although the changelogs are in fact up to date.

cc @imath and @lriaudel who experienced similar issues.

Related Twitter discussion:

#11 @ocean90
3 years ago

  • Milestone WordPress.org deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version 4.7.1 deleted

Duplicate of #meta2750.

Note: See TracTickets for help on using tickets.