WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#39649 closed enhancement (wontfix)

$doaction variable doesn't follow the naming conventions in edit-comments.php:98

Reported by: xayer Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7
Component: Comments Keywords: close
Focuses: Cc:

Description

Hi, on line edit-comments.php:98 (https://core.trac.wordpress.org/browser/tags/4.7/src/wp-admin/edit-comments.php#L98), there's a variable that doesn't follow the guidelines. According to the Naming Conventions (https://make.wordpress.org/core/handbook/best-practices/coding-standards/php/#naming-conventions) it should be $do_action.

<?php
$redirect_to = apply_filters( 'handle_bulk_actions-' . get_current_screen()->id, $redirect_to, $do_action, $comment_ids ); ?>

Even the documentation doesn't follow the guidelines on:
https://developer.wordpress.org/reference/hooks/handle_bulk_actions-get_current_screen-id/()

Change History (2)

#1 @azaozz
4 years ago

  • Component changed from Quick/Bulk Edit to General
  • Keywords close added

Unfortunately $doaction is a global that has been used for many years, long before there were any guidelines or naming conventions. Renaming it is out of the question (break back-compat).

#2 @SergeyBiryukov
4 years ago

  • Component changed from General to Comments
  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.