WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 3 years ago

#39760 closed defect (bug) (wontfix)

Twenty Fourteen: Featured Content tag can't be blank

Reported by: gemmaevans Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7.2
Component: Bundled Theme Keywords:
Focuses: Cc:

Description

A user posted on the WordPress.com forums for advice about why sticky posts were appearing on their static front page, rather than only on the posts page:

http://en.forums.wordpress.com/topic/sticky-blog

We discovered that if no posts match the featured content tag, sticky posts will be displayed instead.

What I expected

I expected to be able to remove the Featured Content (and sticky posts) area from a static front page and only have it show on the posts page.

The Customizer lets me remove and save an empty 'Tag name' field. If I navigate away from the Customizer and go back into Featured Content, the featured tag appears back in the 'Tag field'. I have replicated this behaviour on both my self hosted site and my WordPress.com test site.

Attachments (1)

featurd-content-tag.jpg (248.3 KB) - added by gemmaevans 5 years ago.

Download all attachments as: .zip

Change History (6)

This ticket was mentioned in Slack in #forums by zoonini. View the logs.


5 years ago

#2 @gemmaevans
5 years ago

  • Summary changed from Saving blank tag field on Twenty Fourteen to Twenty Fourteen: Featured Content tag can't be blank

#3 @gemmaevans
5 years ago

Steps to reproduce:

  1. In the Customizer’s Static Front Page panel, set static front page and posts page
  1. In Posts > Add New, create a new post and mark it as sticky
  1. In the Customizer’s Featured Content panel, remove the ‘Tag name’ then Save and Publish
  1. Click back arrow to Customizer options
  • If you don’t leave the Customizer and then go back into Featured Content, the ‘Tag name’ field remains blank
  1. Navigate away from the Customizer completely, to a post or page
  1. Go back to the Customizer’s Featured Content panel — the ‘Tag name’ field now contains the tag that was removed

#4 @SergeyBiryukov
5 years ago

  • Component changed from Themes to Bundled Theme

#5 @laurelfulford
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Thanks for reporting this ticket, @gemmaevans! I can recreate the issue with the featured field not clearing, too.

It looks like the theme is working as designed, as far as the fallback behaviour, though (showing sticky posts when there are none marked as featured). Going off the instructions at the top of the panel, I would expect it to continue doing that, whether or not the field could be cleared.

It might be possible to update the theme to allow the field to be left blank, but that wouldn't really fix what this user is experiencing -- and I'm also a bit worried it would cause more confusion than how it works now.

I'm going to close this as a wontfix based on the above, but please let me know if you have any questions at all about this!

Note: See TracTickets for help on using tickets.