WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 6 months ago

#39765 closed defect (bug) (worksforme)

Siteurl and Home URL Not Updating

Reported by: dchenko Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7.2
Component: Options, Meta APIs Keywords: reporter-feedback close
Focuses: Cc:

Description

I've been having SSL issues on my site driving me crazy (I'm not a novice developer), and today I decided to look into the database. When I looked at the WordPress Address (URL) and the Site Address (URL) fields in the site's settings, both displayed the website as https://mysite.com (that is, with the "s" in "https"). But when I looked into the database, both were just plain "http".

This seems very odd, especially since when both of the fields in the settings were showing "https" and I clicked "Save Changes" it gave me a "Settings saved" confirmation. But when I look into the database again, nothing changed and both URLs are just "http".

I was logged into the admin area with https when this was happening, so maybe the fields were somehow filled out automatically with "https" in the start of the site URL and home URL because I was logged in with https. Or is it something else? Why did the two fields for the URLs not display what was saved in the database? And why weren't the settings saved when I clicked Save?

Change History (8)

#1 @MaximeCulea
4 years ago

  • Component changed from General to Options, Meta APIs
  • Keywords needs-patch needs-screenshots 2nd-opinion added

#2 @MaximeCulea
4 years ago

  • Keywords needs-screenshots removed

#3 @SergeyBiryukov
4 years ago

  • Keywords reporter-feedback added; needs-patch 2nd-opinion removed

Hi @dchenko, welcome to Trac! Thanks for the report.

Does the issue still happen with all plugins disabled and a default theme (Twenty Seventeen or Twenty Sixteen) activated?

Any additional details about your SSL configuration (like FORCE_SSL_ADMIN, etc.) and the steps to reproduce the issue on a clean install would be helpful.

#4 follow-up: @dchenko
4 years ago

  • Keywords needs-patch added

Hello. I have only a few plugins (all are good, non-buggy plugins) and a pretty standard popular theme when this happens. Unfortunately, I can't change my theme or disable plugins because it's a live site.

I don't have any non-default SSL configurations with anything like FORCE_SSL_ADMIN.

#5 @MaximeCulea
4 years ago

  • Keywords needs-patch removed

Hi @dchenko,

You first need to follow these steps :
https://premium.wpmudev.org/blog/ssl-https-wordpress

But also need forcing ssl : https://codex.wordpress.org/Administration_Over_SSL

If you are not à developer, you can use this kind of plugin : https://fr.wordpress.org/plugins/wp-force-ssl/

Tell us if it changed something, thx.

#6 in reply to: ↑ 4 @SergeyBiryukov
4 years ago

Replying to dchenko:

I can't change my theme or disable plugins because it's a live site.

You could always create a copy of the site on a local server for testing purposes, or create a separate clean install on the same server.

#7 @hellofromTonya
7 months ago

  • Keywords close added

Helo @dchenko,

Welcome to WordPress Trac.

Does this issue persist today? If yes, please provide more details to help us investigate:

  • Are these constants defined in your wp-config.php (or elsewhere) per this doc?
define( 'WP_HOME', 'http://example.com' );
define( 'WP_SITEURL', 'http://example.com' );
  • Are the URL options being updated in the theme or a plugin (see this doc)?
update_option( 'siteurl', 'http://example.com' );
update_option( 'home', 'http://example.com' );
  • Does the issue still happen with all plugins are disabled and a default theme (such as Twenty Seventeen) is activated?
  • What are the steps to reproduce the issue on a clean install?

For now, marking as a close candidate. Why? Not finding similar reports of this issue. I suspect the problem is in the stack coming from configuration, plugin, or theme, rather than from WordPress core. However, will review when/if more feedback is given.

#8 @hellofromTonya
6 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Closing this ticket. However, if the problem persists, please reopen and provide more information to help us further investigate.

Note: See TracTickets for help on using tickets.