WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#39789 closed defect (bug) (invalid)

Posting comments via API results in 401 unauthorized

Reported by: martinmalinda Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7.2
Component: Comments Keywords: close
Focuses: administration, rest-api Cc:
PR Number:

Description

Even though in settings I have checked that anyone can post comments (+ approval), server returns 401 unauthorized on these requests.

However, those posts do get saved in the database and they do show up in the article section in wp-admin, but the email notification about new post is not sent.

If the approvals are turned off, it seems like the comments are rejected altogether and they do not show up in the wp-admin.

{"code":"rest_comment_login_required","message":"Sorry, you must be logged in to comment.","data":{"status":401}}

Change History (4)

#1 @SergeyBiryukov
3 years ago

  • Component changed from HTTP API to Comments

#2 @swissspidy
3 years ago

This is by design, see #38855

#3 @rachelbaker
3 years ago

  • Focuses javascript removed
  • Keywords close added

#4 @swissspidy
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.