WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#39801 closed defect (bug) (invalid)

Not receiving password reset email messages for my WP.org sites

Reported by: wolflegal Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7.2
Component: Login and Registration Keywords:
Focuses: administration Cc:
PR Number:

Description

It appears that WP version 4.7.2 created some sort of problem when trying to reset one's site password(s). A couple of weeks ago when the version was still 4.7.1, I received the password reset email message just fine. Now, no matter how many times I try, and no longer how I wait, I never receive the password reset email messages; thus, I am completely locked out of the wp-admin page for one of my sites. I think this correction needs to be made immediately or as soon as practicably possible. Thank you.

Change History (24)

#1 follow-ups: @hardeepasrani
3 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Hey there,

It seems like a support question so did you try posting your question in the support forum first as it could be an issue with your server/hosting as well? Please post your question here: http://wordpress.org/support/

Thank you. :)

#2 @wolflegal
3 years ago

I don't know what was wrong; but, for the heck of it, I just tried to login again, and this time I was able to get in using the same password that I had been using for a couple of weeks.

#3 @hardeepasrani
3 years ago

Haha, glad to hear that. :)

#4 in reply to: ↑ 1 @wolflegal
3 years ago

No, I believe it may be a bug issue, or at least it appeared to be. I've never had login or password reset problems before.

Replying to hardeepasrani:

Hey there,

It seems like a support question so did you try posting your question in the support forum first as it could be an issue with your server/hosting as well? Please post your question here: http://wordpress.org/support/

Thank you. :)

#5 @wolflegal
3 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

#6 in reply to: ↑ 1 @wolflegal
3 years ago

I thought it might be a server/host problem as well, so I already contacted GoDaddy a couple of days ago (their customer service is getting worse and worse), and I haven't heard back from them (yet?). As is typical of companies, if I ever receive a response, they will probably blame it on WP, and you guys will blame it on GoDaddy [that's who the WP account email address is with too, but I always received password reset messages there with no problem(s) before].

Replying to hardeepasrani:

Hey there,

It seems like a support question so did you try posting your question in the support forum first as it could be an issue with your server/hosting as well? Please post your question here: http://wordpress.org/support/

Thank you. :)

Last edited 3 years ago by wolflegal (previous) (diff)

#7 follow-ups: @hardeepasrani
3 years ago

  • Focuses accessibility removed

Try to install Postman SMTP to see if your server is able to send emails: https://wordpress.org/plugins/postman-smtp/

#8 in reply to: ↑ 7 @wolflegal
3 years ago

Excellent suggestion. I just installed and activated it (successfully), configured it (successfully), and sent a test email (successfully), and I received the test email in the GoDaddy email address inbox, directly on GoDaddy's website. What does this mean? I can't test to see if I'll receive the password reset messages again or not, because I don't want to change the password again.

Replying to hardeepasrani:

Try to install Postman SMTP to see if your server is able to send emails: https://wordpress.org/plugins/postman-smtp/

Last edited 3 years ago by wolflegal (previous) (diff)

#9 follow-up: @hardeepasrani
3 years ago

Try to reset your password again. You can just ignore that email and not change your password. You aren't required to change your password. :)

#10 in reply to: ↑ 7 @wolflegal
3 years ago

Btw, is that true that we now have to use at least 12-character passwords in wp.org sites, or is that only on the WP.org website where I just successfully reset my password?

Replying to hardeepasrani:

Try to install Postman SMTP to see if your server is able to send emails: https://wordpress.org/plugins/postman-smtp/

#11 @hardeepasrani
3 years ago

It's your site, you can us whatever you want as your password. Did you try to reset password again? Please check your spam folder too for the mail.

#12 in reply to: ↑ 9 @wolflegal
3 years ago

I just successfully changed the email while logged into the site, and I received that confirmation email message. Then I tried logging out and sending a password reset message, and I received the reset email message this time just fine. Did the plugin somehow fix the problem? And should I leave the plugin activated, or should I deactivate it? I will install, activate and run it on my other wp.org site as well, in case problem is occurring there too.

Replying to hardeepasrani:

Try to reset your password again. You can just ignore that email and not change your password. You aren't required to change your password. :)

Last edited 3 years ago by wolflegal (previous) (diff)

#13 follow-up: @hardeepasrani
3 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

Nope, the plugin was there for the last test, not this one. So yea, it appears to be an issue from your hosting provider's side, not in WordPress core. So please for such issues create a support ticket in WordPress support forum, as Trac is for development and bugs with the core. Thank you. :)

#14 in reply to: ↑ 13 @wolflegal
3 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Well then, if the plugin didn't correct the problem, how is it suddenly working when I did nothing to else to try and correct the issue?

Replying to hardeepasrani:

Nope, the plugin was there for the last test, not this one. So yea, it appears to be an issue from your hosting provider's side, not in WordPress core. So please for such issues create a support ticket in WordPress support forum, as Trac is for development and bugs with the core. Thank you. :)

#15 follow-up: @hardeepasrani
3 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

I really have no idea about that. Please don't reopen the ticket as it's not a bug with the core. You can leave comments without reopening as well. :)

#16 in reply to: ↑ 15 @wolflegal
3 years ago

How do you know that it's "definitely" a problem on the hosting provider's side and not a WP bug, if the plugin didn't correct the problem or GoDaddy didn't just happen to correct the problem while I was working on the issue per your instructions [I have still received no reply from GoDaddy to inform me that the issue was corrected, if indeed it was on their side (which it probably wasn't)]?

Replying to hardeepasrani:

I really have no idea about that. Please don't reopen the ticket as it's not a bug with the core. You can leave comments without reopening as well. :)

Last edited 3 years ago by wolflegal (previous) (diff)

This ticket was mentioned in Slack in #core by hardeepasrani. View the logs.


3 years ago

#18 in reply to: ↑ 17 @wolflegal
3 years ago

Does Slack require a separate registration/account? (I tried using the login for this site, and it won't work.)

Replying to slackbot:

This ticket was mentioned in Slack in #core by hardeepasrani. View the logs.

#19 follow-up: @jnylen0
3 years ago

@wolflegal as previously stated, this forum is for specific issues with the core WordPress code, and fixing them via unit tests and patches. Support requests should instead go through the forums or IRC.

Here is what would be needed in order for this to be a valid core.trac ticket:

  • Clear and specific steps to reproduce this issue, from a fresh installation of the latest version of WordPress.
  • Proof that your site's email configuration is working as intended.

Then, in order to get the problem fixed:

  • The specific location in the WordPress code where there is a bug.
  • A failing automated test case for the specific bug.
  • A patch attached to the ticket that does not break other WP sites or introduce other issues.

Getting a WordPress site to send email in particular can be quite complicated, and depends greatly on the configuration of your hosting provider. As such, this issue should start out as a support request in the forums or IRC, and core.trac is not the right place for this request until you have at least a few of the bulleted items above.

I agree with @hardeepasrani on the most likely explanation for this issue: GoDaddy had a temporary problem with their email configuration, which they then fixed.

#20 follow-up: @swissspidy
3 years ago

  • Milestone Awaiting Review deleted

@wolflegal See https://make.wordpress.org/chat/ for WordPress Slack sign-up procedure. Please note that the Slack team is not for support, but for coordinating work on WordPress.

#21 in reply to: ↑ 19 @wolflegal
3 years ago

Oh, would you guys please stop being arrogant, officious and self-superior. I didn't understand all of that, but I'm here now, and it may be a bug with 4.7.2, though I didn't technically supply the ticket properly, not knowing how it's done. So, why don't you just answer my question from my second-previous message (the first of the two), and we'll be done, okay?

Also, I have had bad experiences with the forum where my messages are never answered and my very limited energy is wasted (I am highly physically disabled and don't have ANY energy to waste).

In case you don't want to "read-back" in the messages, here is my last question, as follows:

"How do you know that it's 'definitely' a problem on the hosting provider's side and not a WP bug, if the plugin didn't correct the problem or GoDaddy didn't just happen to correct the problem while I was working on the issue per your instructions [I have still received no reply from GoDaddy to inform me that the issue was corrected, if indeed it was on their side (which it probably wasn't)]?"

And, P.S., just as I said you would like do, you (arbitrarily and/or automatically) blame the entire problem on the host, as GoDaddy would likely do too (if they aren't already and I just haven't heard about it yet), blaming it all on WP. It is very unlikely that it was a hosting problem, because I've NEVER had this problem before, or any similar problem(s), with the host [I've been with GoDaddy for over ten years (since at least 2004 or 2005, if not earlier), and I've had my WP blogs hosted with them for over ten years also (since 2005)]. So, because I'm not a techie, and I didn't post a ticket correctly, you're acting like you're supposedly "superior" to me (when, btw, NO ONE is superior to ANYONE else), and evidently won't look into whether or not this is actually a WP 4.7.2 bug, and/or are refusing to do so.

I hope you are actually looking into it, or will, and will stop being self-superior, officious and arrogant.

Replying to jnylen0:

@wolflegal as previously stated, this forum is for specific issues with the core WordPress code, and fixing them via unit tests and patches. Support requests should instead go through the forums or IRC.

Here is what would be needed in order for this to be a valid core.trac ticket:

  • Clear and specific steps to reproduce this issue, from a fresh installation of the latest version of WordPress.
  • Proof that your site's email configuration is working as intended.

Then, in order to get the problem fixed:

  • The specific location in the WordPress code where there is a bug.
  • A failing automated test case for the specific bug.
  • A patch attached to the ticket that does not break other WP sites or introduce other issues.

Getting a WordPress site to send email in particular can be quite complicated, and depends greatly on the configuration of your hosting provider. As such, this issue should start out as a support request in the forums or IRC, and core.trac is not the right place for this request until you have at least a few of the bulleted items above.

I agree with @hardeepasrani on the most likely explanation for this issue: GoDaddy had a temporary problem with their email configuration, which they then fixed.

Last edited 3 years ago by wolflegal (previous) (diff)

#22 in reply to: ↑ 20 @wolflegal
3 years ago

I was just trying to see what "@hardeepasrani" wrote on Slack about this thread, by my going to the "logs" link and attempting to login.

Replying to swissspidy:

@wolflegal See https://make.wordpress.org/chat/ for WordPress Slack sign-up procedure. Please note that the Slack team is not for support, but for coordinating work on WordPress.

#23 follow-up: @jnylen0
3 years ago

I agree with you it's not about superiority, rather we don't have enough information to look into this as a valid WP bug. Password resets work fine on my sites. This is also the first report we've received of such an issue with 4.7.2, and if it was a WP bug there would have been many other reports by now. Therefore the most likely explanation is a temporary problem with the server/hosting configuration.

#24 in reply to: ↑ 23 @wolflegal
3 years ago

Thank you, that's a very kind reply.

Replying to jnylen0:

I agree with you it's not about superiority, rather we don't have enough information to look into this as a valid WP bug. Password resets work fine on my sites. This is also the first report we've received of such an issue with 4.7.2, and if it was a WP bug there would have been many other reports by now. Therefore the most likely explanation is a temporary problem with the server/hosting configuration.

Note: See TracTickets for help on using tickets.