WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 3 years ago

#39812 closed defect (bug) (duplicate)

Twenty Sixteen subscript and superscript inverted in editor

Reported by: pascallj Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7.2
Component: Bundled Theme Keywords: has-patch
Focuses: Cc:

Description

When creating a page in the page editor and making use of the HTML tags <sub></sub> or <sup></sup> in the text editor, the corresponding tags are inverted in the display when switching to the visual representation.
A subscript is therefore displayed as a superscript in the editor and vice versa. The tags itself stay untouched, it's just the visual representation in the editor.

Change History (9)

#1 follow-up: @swissspidy
5 years ago

  • Keywords reporter-feedback added

Hey there,

Thanks for your report and welcome to WordPress Trac.

I cannot reproduce this on the latest version of WordPress running Twenty Seventeen. Can you confirm that this bug still occurs when disabling all plugins and using Twenty Seventeen? Perhaps something is messing with the CSS.

You might also want to look in your browser's developer console if the visual editor uses the correct HTML tags and what styling is applied to them.

#2 in reply to: ↑ 1 @pascallj
5 years ago

You are right. This does only happen when using the theme Twenty Sixteen. I didn't know the theme had influence on the editor.

I confirmed with the Developer Console that it is indeed just the styling of the tags which is inverted in the theme and not the tags themself.

#3 @swissspidy
5 years ago

  • Component changed from Editor to Bundled Theme
  • Keywords has-patch added; reporter-feedback removed
  • Milestone changed from Awaiting Review to 4.8
  • Summary changed from Subscript and superscript inverted in editor to Twenty Sixteen subscript and superscript inverted in editor

I can confirm the issue with Twenty Sixteen enabled. sub and sup are swapped in the CSS.

There's already a pull request on GitHub (from November!): https://github.com/WordPress/twentysixteen/pull/490

Note that Twenty Sixteen is the only default theme still maintained on GitHub, the others moved to trac completely. Still, we keep tickets for Twenty Sixteen here as well.

This ticket was mentioned in Slack in #design by swissspidy. View the logs.


5 years ago

#5 @ocean90
5 years ago

  • Milestone 4.8 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Still, we keep tickets for Twenty Sixteen here as well.

Since Twenty Sixteen is developed and maintained only on GitHub we don't keep tickets here.

Last edited 5 years ago by ocean90 (previous) (diff)

#6 @swissspidy
5 years ago

#40867 was marked as a duplicate.

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


5 years ago

#8 @SergeyBiryukov
5 years ago

  • Milestone set to Awaiting Review
  • Resolution invalid deleted
  • Status changed from closed to reopened

Reopening, as there's a consensus on merging Twenty Sixteen into core SVN in #36497.

#9 @laurelfulford
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from reopened to closed

Thank you for this report, @pascallj!

This looks like it was fixed in a later ticket, #44776; this should be available in the latest version of Twenty Sixteen, 1.7.

I'm going to close as a duplicate of that later ticket, so they're linked together.

Note: See TracTickets for help on using tickets.