WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 7 months ago

#39818 closed defect (bug) (duplicate)

Bulk Publishing Posts (from Pending State) Causes Pagination To Break

Reported by: CrazyEngineers Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7.2
Component: Query Keywords:
Focuses: Cc:
PR Number:

Description

Steps: -

  1. Create about 30 posts, all in 'pending' state.
  1. In admin panel, bulk edit all these posts and change status to 'publish'

Observe: The order of the posts gets messed up in the admin panel. If pagination is in place, you can notice duplicate posts on pages.

Apparently, the 'publish date' of the posts is messed up at the time of bulk publishing all the posts. WP_Query cannot decide how to paginate posts because multiple posts would have the same publishing time (unix timestamp).

Notes: I encountered this bug at the time of creating posts using a script (to test my plugin). I could reproduce it on two different servers; but not on my local machine with exported XML.

Change History (1)

#1 @SergeyBiryukov
7 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi @CrazyEngineers, welcome to WordPress Trac!

Thanks for the report, sorry it took so long for someone to get back to you.

I'm closing the ticket in favor of #44349, which appears to have more details and traction.

Note: See TracTickets for help on using tickets.