WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#39880 closed defect (bug) (duplicate)

PHP Notice: Undefined index: host in canonical.php on line 444

Reported by: romgo Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7.2
Component: Canonical Keywords: has-patch
Focuses: Cc:

Description

Hello,

I am having this message in my error log :

PHP Notice: Undefined index: host in <removed>/www/wp-includes/canonical.php on line 444
PHP Notice: Undefined index: host in <removed>/www/wp-includes/canonical.php on line 445
PHP Notice: Undefined index: host in <removed>/www/wp-includes/canonical.php on line 445
PHP Notice: Undefined index: host in <removed>/www/wp-includes/canonical.php on line 446
PHP Notice: Undefined index: host in <removed>/www/wp-includes/canonical.php on line 448

running wordpress 4.7.2

This message is coming from my nagios server, can reproduce with :

./check_http -S $hostname

Maybe the issue is coming from the fact that $hostname is not the name of my public URL.

If need more information feel free to ask.

Attachments (1)

39880.patch (970 bytes) - added by yahil 2 years ago.

Download all attachments as: .zip

Change History (3)

@yahil
2 years ago

#1 @bhargavbhandari90
2 years ago

  • Keywords has-patch added

#2 @SergeyBiryukov
2 years ago

  • Component changed from General to Canonical
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi @romgo, welcome to WordPress Trac!

Thanks for the report, we're already tracking this issue in #34353.

Note: See TracTickets for help on using tickets.