WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#39885 closed defect (bug) (invalid)

Wordpress editor is not accessible on the Mac using VoiceOver

Reported by: zhenikar Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Editor Keywords: reporter-feedback
Focuses: accessibility Cc:
PR Number:

Description

I'm a blind Web developer and have a very difficult time using the Wordpress editor. When I am on the main editing pane, the screen reader does not read the contents of my text, nor does it stay in one place. Every time I do a carriage return, my cursor jumps to the top of the page--very frustrating. It also will not read anything but, "Blank line." Also frustrating.

I need to create the page in another program and paste the code into Wordpress, but that also creates an issue when I need to edit a page.

Maybe there is something I am missing to make the editor more accessible?

Change History (7)

#1 @iseulde
3 years ago

Hi zhenikar!

Welcome to Trac! Thanks for reporting this problem, we'd be happy to try to make the editor more accessible. Did this problem start recently, or has it always been like this? Which browser are you using VoiceOver with? It'd be good to know so we can reproduce the issues. What other program are you using to create the page before pasting it into WordPress? It sounds like we could learn a lot from that program to make WordPress work better for you. :)

#2 @afercia
3 years ago

  • Version 4.7.2 deleted

Hello @zhenikar and welcome to Trac! Which browser are you using together with VoiceOver? Unfortunately not all browsers and screen readers combinations work well in the editor (and also outside of the editor). The recommended browser for VoiceOver is Safari. Though navigation through text in the editor is sometimes difficult, most of the VoiceOver shortcuts for reading text work decently with Safari 10, at least for me.

Instead, when I try to use VoiceOver with Chrome, I can reproduce some of the issues you described. As far as I know, they're working to improve Chrome compatibility with VoiceOver, see for example this ticket on the Chromium bug tracker: https://bugs.chromium.org/p/chromium/issues/detail?id=530826

If this is not the case, could you please describe your setup and workflow?

I'd also suggest to try the "Text mode". The editor has two modes: "Visual" and "Text". Before the editor, there are two buttons to switch mode. The "Text" mode gives you an ordinary textarea that should be simpler to use.

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


3 years ago

#4 @afercia
3 years ago

  • Keywords reporter-feedback added

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


3 years ago

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


3 years ago

#7 @joedolson
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Without any further feedback, we simply don't have enough information to move forward on this. Given the vast problems that can be caused by site builder integrations in themes and plug-ins, there's a very good possibility this is not a core WordPress issue, and we haven't been able to reproduce it using standard installations.

Note: See TracTickets for help on using tickets.