WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#39981 closed defect (bug) (invalid)

Multisite Domain Mapping doesn't work or not activated at all

Reported by: avibrazil Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7.2
Component: Networks and Sites Keywords:
Focuses: multisite Cc:
PR Number:

Description

The documentation at 【1】 can't be done on a 4.7.2 WordPress installation, which is higher than the minimum 4.5+ suggested in the article.

When editing the domain, the "Site Address (URL)" field isn't editable.

So either the documentation is wrong (which I doubt) or the native domain mapping function for multisite is somehow disabled on 4.7.2.

【1】 https://codex.wordpress.org/WordPress_Multisite_Domain_Mapping#Using_a_Dedicated_IP

Change History (7)

#1 follow-up: @Ipstenu
3 years ago

  • Resolution set to invalid
  • Status changed from new to closed

The documentation is out of date (so yes, it's wrong). Also it's totally wrong about requiring a dedicated IP...

Just edit the Site Address to what you want, save, done. Tested this on 4.6 and 4.7 and 4.8 and it works :)

#2 @SergeyBiryukov
3 years ago

  • Milestone Awaiting Review deleted

#3 in reply to: ↑ 1 @avibrazil
3 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Replying to Ipstenu:

Just edit the Site Address to what you want, save, done. Tested this on 4.6 and 4.7 and 4.8 and it works :)

So you didn't read me previous post where I said the following:

THE “Site Address (URL)” FIELD IS NOT EDITABLE IN MY FRESH 4.7.2 INSTALLATION. I can see the URL but can't edit it.

So besides de wrong documentation, apparently there is a bug in current WordPress.

#4 @netweb
3 years ago

  • Milestone set to Awaiting Review

#5 follow-up: @Ipstenu
3 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

Please don't shout. I did read that. That's not what I see on a clean install, unless I'm trying to edit the main site on the network.

Which shouldn't be a question of 'mapping' because you don't map the primary domain on the network. If you're trying to map your primary domain, then that's why you can't edit it, and this is by design.

You're not supposed to change the main domain of your network unless you seriously totally 10000% know what you're doing, because you could very easily break everything.

https://core.trac.wordpress.org/browser/trunk/src/wp-admin/network/site-info.php#L161

Multisite can be pretty dangerous. If you change the primary domain you need to use serialization safe search/replace.

#6 @netweb
3 years ago

  • Milestone Awaiting Review deleted

#7 in reply to: ↑ 5 @avibrazil
3 years ago

Replying to Ipstenu:

You're not supposed to change the main domain of your network unless you seriously totally 10000% know what you're doing, because you could very easily break everything.

You were right. I can edit other domains but not the main. Thank you

Last edited 3 years ago by avibrazil (previous) (diff)
Note: See TracTickets for help on using tickets.