WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#3999 closed defect (bug) (wontfix)

slow rss generation

Reported by: dennyvatvfamily Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.1.2
Component: General Keywords: rss php 5.2.1
Focuses: Cc:

Description

After upgrading php from 5.1.6 to 5.2.1 the rss feed generation from Wordpress is very slow.

A page that parse the rss2 feed from wordpress would take about 15 seconds to load.

I've tested the issue with my blog and with blogs using wordpress and php 5.2.1 from around the web. I have also used different php parsers to parsing wordpress rss generated feeds (Magpie).

Tested on Gentoo Linux (Apache 2.0.58 + php 5.2.1-r3) as feed generator and parser, and Mac OS X (Apache 1.3 + php 4.4) as parser.

Change History (2)

comment:1 @dennyvatvfamily8 years ago

I think it's related to a php 5.2.1 data handling bug. See http://bugs.php.net/bug.php?id=40261 for more information.

Thanks.

comment:2 @Nazgul8 years ago

  • Resolution set to wontfix
  • Status changed from new to closed

Seeing this isn't an issue caused by Wordpress and a workaround seems not to be possible, I'll close this as wontfix.

Note: See TracTickets for help on using tickets.