WordPress.org

Make WordPress Core

Opened 15 years ago

Closed 15 years ago

#4002 closed defect (bug) (duplicate)

Category name field width too small for multilingual plugins

Reported by: jhodgdon Owned by:
Milestone: Priority: low
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description

Several multilingual plugins require you to put multiple language text into various fields of the WordPress database, such as post titles, content, etc.

There is usually no problem with this, since most of the fields are plenty large to contain two or three versions of the text, along with the language indicator tags. The one exception to this is the field for the name of categories, which is only 55 characters wide. A 200 character field width would be better.

I realize you may not want to apply this patch, but I figured it was worth a try. For now, the work-around has been to instruct plugin users to basically apply this patch manually.

Attachments (1)

upgrade-schema-php.diff (641 bytes) - added by jhodgdon 15 years ago.
Patch to change the category title field to 200 characters

Download all attachments as: .zip

Change History (6)

@jhodgdon
15 years ago

Patch to change the category title field to 200 characters

#1 @jhodgdon
15 years ago

  • Keywords has-patch added

#2 @jhodgdon
15 years ago

  • Summary changed from Category title field width too small for multilingual plugins to Category name field width too small for multilingual plugins

#3 @rob1n
15 years ago

  • Keywords dev-feedback added; category database removed
  • Version 2.2 deleted

To me, this seems like a pretty bad/hacky way to incorporate multiple languages, though I can (sort of) see the use of lengthening the field for category_name and other fields. Or even making them use TEXT fields rather than VARCHAR.

#4 @rob1n
15 years ago

  • Component changed from i18n to General

#5 @charleshooper
15 years ago

  • Keywords dev-feedback has-patch removed
  • Milestone 2.2 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #3729

Note: See TracTickets for help on using tickets.