WordPress.org

Make WordPress Core

Opened 8 months ago

Closed 6 months ago

Last modified 6 months ago

#40074 closed defect (bug) (duplicate)

Invalid link markup in head

Reported by: henry.wright Owned by: rmccue
Milestone: Priority: normal
Severity: normal Version: 4.4
Component: REST API Keywords:
Focuses: Cc:

Description

The rel attribute value must be a valid keyword.

<link rel='https://api.w.org/' href='https://example.com/wp-json/' />

To be clear, https://api.w.org/ isn't a keyword.

Change History (6)

#1 @SergeyBiryukov
8 months ago

  • Component changed from General to REST API
  • Version changed from 4.7.3 to 4.4

Related: #34303

#2 @joehoyle
7 months ago

  • Owner set to rmccue
  • Status changed from new to assigned

Assigning to @rmccue as he know much more about this than me! @rmccue are we using some other spec or reasoning here? Either way, I'm not sure we can change it now.

#3 @rmccue
6 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #37841.

#4 @henry.wright
6 months ago

@rmccue #37841 is closed. Does that mean this issue is a wontfix? After reading your research on the conflicting specifications I'm not sure if the issue still needs addressing.

#5 @rmccue
6 months ago

@henry.wright It was added to the Microformats wiki page, which means it's a valid relation per the spec. :) The resolution really should be "fixed" instead, will change that.

#6 @henry.wright
6 months ago

@rmccue I see! Thanks for clarifying

Note: See TracTickets for help on using tickets.