WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 2 years ago

#40091 closed defect (bug) (worksforme)

Fatal Error and PHP shutdown leading to 503 errors rss_functions.php

Reported by: bigflannel Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7.3
Component: Feeds Keywords:
Focuses: Cc:

Description

I'm not sure this is a bug. Apologies if not. I noticed it on two installations today, different domains, different VPS servers, different hosting companies. Each website was returning a 503 error. I restarted PHP on each server and each site returned.

The PHP logs for each site have an entry like this:

child 24048 said into stderr: "NOTICE: PHP message: PHP Fatal error:  Uncaught Error: Call to undefined function _deprecated_file() in /var/www/vhosts/clampart.com/httpdocs/wp-includes/rss-functions.php

followed by an entry regards stack trace.

One website is running on PHP-FPM 7.0.16 the other on PHP-FPM 7.1.2. Both are 4.7.3.

Regards
Mike

Change History (1)

#1 @desrosj
2 years ago

  • Component changed from General to Feeds
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Hi @bigflannel,

Welcome to Trac! I'm sorry that it took so long to receive a response to this ticket.

Since it has been such a long time and I could not find any similar reports, I am going to close this issue out. But, if you are still experiencing this issue and can provide detailed steps someone else can use to reproduce, please do reopen the ticket for further investigation. Thank you!

Note: See TracTickets for help on using tickets.