WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 9 months ago

#40137 closed defect (bug) (duplicate)

Twenty Seventeen: Unordered list inner the ordened continue counting in the editor

Reported by: edpittol Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7
Component: Bundled Theme Keywords: has-screenshots has-patch
Focuses: ui Cc:

Description

In editor, when have an unordered list inner the ordened, the item continue counting and affect the remainder list.

Attachments (3)

current.png (51.7 KB) - added by edpittol 3 years ago.
The current state
expected.png (50.9 KB) - added by edpittol 3 years ago.
The expected state
editor-unordered-inner-ordened.40137.diff (526 bytes) - added by edpittol 3 years ago.

Download all attachments as: .zip

Change History (6)

@edpittol
3 years ago

The current state

@edpittol
3 years ago

The expected state

#1 @swissspidy
3 years ago

  • Keywords has-screenshots needs-patch added
  • Milestone changed from Awaiting Review to Future Release

Thanks for your report and the screenshots, @edpittol!

#2 @toddhalfpenny
17 months ago

  • Keywords has-patch added; needs-patch removed

#3 @laurelfulford
9 months ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks so much for your work on this, @edpittol!

After some back and forth on it, I belatedly realized #44775 is kind of a duplicate of this issue. It's also about the numbering in the ordered lists not being correct. The fix is a bit different though: the bolded numbered styles were actually removed from Twenty Seventeen before it launched, but left in the editor styles. So the patch in #44775 removes them from the editor.

Had I caught this sooner, I would have given that recommendation for your patch. Since the one in #44775 already has them removed, I'm going to close this ticket in favour of that one. But I will add a note there that you should get props in the commit as well for your work here.

If you have any questions about this, just let me know. Apologies for catching this so late!

Note: See TracTickets for help on using tickets.